iMOD Forum

To report a problem/bug or request a new feature,
please go to its subcategory in 'iMOD-GUI' or 'iMODFLOW' below


First-time users: please have a look here for info on the iMOD forum-principles.

« Back to User questions

Default projection

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Default projection
imod simulation projection pathline flowpath coordinates amersfoort rdnew default
Answer (Unmark)
7/15/16 8:30 PM
Hi,

I'm doing a research focussed on pathline simulations, but still pretty new on working with iMOD.
The manual states that the default projection is WGS84 EPSG:28992 Amersfoort RDnew.
This is obviosuly centered on Amersfoort, but I'd actually like to run pathline simulations for the whole world,
where this projection gives great deformations for Australia for example.
Is it possible to change the default projection somewhere?
(This is of great significance, as all my input data is in degrees, while the unit of iMOD is meters).

Thank you in advance.

Bas
RE: Default projection
Answer (Unmark)
7/16/16 2:50 PMas a reply to Bas van Dijk.
Hi Bas,

At this moment we work in iMOD on a groundwater model for the Ganga basin, India.
Our Projection is the Lambert projection (EPSG 02030), a XY projection.

You don't need to use the Amersfoort projection.
iMOD is XY based so as long as you pick a XY projection it is no problem.
The line in the Manual about the WGS84 EPSG:28992 projection needs a revision.

Kind regards,

Frans
RE: Default projection
Answer (Unmark)
7/19/16 12:31 AMas a reply to Frans Roelofsen.
Hi Frans,

Thank you for the quick and clear response.

I won't use the WGS84 EPSG:28992 Amersfoort RDnew then.
As all my data (ascii files) is in degrees, I am able to run the model, but the scale is incorrect, and therefore the absolute results of the pathline simulation as well.
I still wonder if it is possible to change the default projection of iMOD to a projection in degrees?

As an alternative appraoch I've been able to transform the projection of all the original ascii files,
which serve as input for iMOD, to a projection in meters (I tried both WGS 1984 Plate Carree and Mollweide).
Now, after changing the model extent and the resolution to meters too, in the runfile, the command prompt is able to run iMODFLOW.
I've noticed a big difference in the command syntax however:

(1)

(2)

(1) represents the conventional process with a runfile, where one still has to deal with the scale disorder.
(2) presents the process where the input data is already transformed to a projection in meters.
There's seems to be no streamflow, as there are no head closure - cell calculations.

The results can still be run in iMOD, but unfortunately no flowpaths appear, and the *.iff file results in the following:

(3)

Particles are released, but no actual flowpath simulations occur.
The time values of 200 years, are simply there because I've set the maximum trace time at 200 yrs.
What do you think obstructs the calculations in the command prompt?
Or what do you think prevents the model from running pathline simulations?


Any thoughts or suggestions would be really appreciated!
Thank you in advance.

Bas
RE: Default projection
Answer (Unmark)
8/18/16 11:19 AMas a reply to Bas van Dijk.
Hi Bas,

After you've transformed your data the model isn't converging anymore - though it says it converges. Probably the "new" model lacks a proper boundary condition or it has some "isolated" gridcells that are not connected anymore. This causes the used PCG solver to fail. Also I saw that you;re using an old version of iMODFLOW (v2.6.45), could you try it with the released iMODFLOW version v3.4?

Kind regards,
Peter Vermeulen
RE: Default projection
Answer (Unmark)
9/13/16 11:55 AMas a reply to Peter Vermeulen.
Hi Peter,

after a while I didn't expect a response anymore,
but here it is, thank you! Unfortunately, the problem is still occuring.

I've not tried to work with a newer version of iMod yet,
as the first simulations with the input files in degrees did acutally present flowpaths.
I have established that my problems so far might have to do something with the settings in the runfile.
The initial runfile where the input files have a projection in degrees are originally from another research,
and is assumed to be correct. The file can be regarded in attachment run1.

As earlier explained, I have tried to change the projection of the input files to meters,
as there is a scale problem using the original input files that are in degrees.
The iMod manual states that the QCLOSE in the runfile is defined as the following:

"Closure criterion for the mass balance. This criterion depends on the
grid size, since large grid cells produce larger errors in mass balances
than smaller ones does."


My self-developed runfile for the reprojected inputs can be viewed in attachment run2.
Obivously the cell size differs for the two files (0.08 vs. 9276.587 respectively), I have not altered QCLOSE however.
Might this be what holds back imodflow?
And more importantly, if yes, what is a more viable value for QCLOSE, or how can I find out?

Thanks again!

Bas
Attachment

Attachment

Attachments: run1.png (45.8k), run2.png (64.5k)
RE: Default projection
Answer (Unmark)
9/15/16 9:40 AMas a reply to Bas van Dijk.
Hi Bas,

I'm afraid I don't understand your question. As as I can see, your model didn't start solving the problem due to some errors in your input data. I've been running a model with degrees (from the UU) succesfully with cellsizes of 0.08. A small detail is that there should be no empty line in your runfile above "ACTIVE MODULES". And it is better to use NSCL=0 and than use the network as described in the IDF file C:\WSM\ASCII\landmarks.idf.

If you still face some issues, you may send me the model, than I can have a better look and understanding of your problem.

Kind regards
Peter Vermeulen
RE: Default projection
Answer (Unmark)
9/20/16 3:17 PMas a reply to Peter Vermeulen.
Hi Peter,

The thing is, imodflow and imod have been run successfully for the initial input files (in degrees) with also a cellsize of 0.08.
The resulting pathlines (attachment 1) seem accurate, however the scale is incorrect, as can be seen in the bottom right corner.
My ultimate goal of this research is to derive the coherent groundwater age of each flowpath from the *.iff file, but due to the error in scale this is not possible.

As I mentioned earlier, to deal with this problem, I've changed the projection of all input files to one in meters. After that the model was not able to solve it anymore.
I suspect this has something to do with solver configuration of the runfile. The empty line above "active modules" does not have any effect.
Using the network as described in the idf file is not completely clear to me. Would you mind elaborating on that?

The input files of the model are quite large (approx. 10 files of 100 Mb), so sending them might be hard.
You can contact me through email, if you would like (in Dutch is fine of course)
b.vandijk4@students.uu.nl

As I am student working on my MSc thesis at the UU, it might be even easier to meet up, if you're open to that.
It could help me out a lot. Thank you in advance.

Bas
Attachment

Attachments: bijlage 1.png (512.6k)
RE: Default projection
Answer (Unmark)
9/21/16 10:34 AMas a reply to Bas van Dijk.
Hi Bas,

Yes, you are always welcome to come over to Deltares.

So, if I understand you correctly, the model is running with the original files (in degrees) with cellsize of 0.08m. Also the particles work fine, to get the right age for the particles you have to alter the porosity-values. Small values will increase the age, and large values will slow it down, but the porosity values will NOT influence the actual path of the particles. In this case, I believe you have to multiply the porosity values with m/0.08 where m stands for the size of the gridcell in meters (so, you have to know how much 1 degree is in meters).

Kind regards,
Peter Vermeulen
RE: Default projection
Answer (Unmark)
9/27/16 3:45 PMas a reply to Peter Vermeulen.
Hi Peter,

Yes the model is running with the original files with cellsize of 0.08 m, which represent the original resolution of 5 arc degrees.
Altering the porosity values has been a great idea!
I've multiplied the porosity with the sqrt(cellsize05min.correct.map)/celllength().
Maps with a different varying cell sizes over the lenght of the earth were use to compensate for the differences in cell sizes.
The results in the *.iff file show adequate time values for the flowpaths.
Using this conversion factor must come with its limitations however.. I suspect that the calculations of the flowpaths are affected by this assumption.

The most desired outcome would still be to reproject the original input files,
and make imodflow and imod work with those. I am certain that the solver configuration of the runfile has something to do with this.
I would really like to come over to deltares and discuss this with you.
Perhaps you can give me your email, or you can send me one,
I stated my email address in my last post before this one.

Thanks again,

Bas
RE: Default projection
Answer (Unmark)
10/20/16 11:23 AMas a reply to Peter Vermeulen.
Hi Peter,

quick question. When trying to run my runfile in imodflow,
the following error occured:

Expecting more input on line [ 1,1.0,0.0, "directory to my bnd file"]

What could be the cause of this? I tried it for both values of 0 and -1 for the sea (i.e. the inactive cells).
Hope to hear from you soon!

Bas
RE: Default projection
Answer (Unmark)
10/24/16 1:04 PMas a reply to Bas van Dijk.
Hi Bas,

Probably something wrong with your runfile. Please send it to me.

Kind regards,

Peter Vermeulen