Back

Import TimeSeries on Exercise 05 not Working for 2014.02 release

Gihan Karunarathne, modified 1 Year ago.

Import TimeSeries on Exercise 05 not Working for 2014.02 release

Youngling Posts: 2 Join Date: 1/4/17 Recent Posts
Hi Fews Devs,

I'm following the introductionary course of Delft-Fews as mentioned here http://oss.deltares.nl/web/delft-fews/linux.
I have successfully setup the 2014.02 Fews System on Ubuntu 14.04 x86, and completed the first four exercises as well. Also I followed the steps which mentioned in Delft-FEWS Downloadable package - Course Exercises.pdf. After ran the Import Workflow (ImportExternal) on Manual Forecast Display, it gives a completed message as below,

INFO -                 ******************      Workflow ImportExternal Completed    ******************
INFO - Start time: 2017-02-09 07:05:19 End time: 2017-02-09 07:05:20 T0: 2008-10-11 00:00:00 User Id:fews
INFO - TaskRun.Completed: Task ImportExternal with ID 3 completed in 1s
INFO - TaskRun.TimeSpend:EaImport 1s 60%  TransformationModule 0s 17%  TimeSeriesImport 0s 17%  datastore 0s 15%  cache files 0 B   database 0s 0% (0 ms/query, 0 B,  0 B/s, 4 queries, 0 rows)  reloaded 0 B  time series read 3 (unique=0)  time series written 6 (changed=5)  files 0s 0%  logging 0s 0%  gc 0s 0%  cpu 147%  max mem. 51 MB  index mem. 2.4 kB  db con. acquire time 0s 0%  lock. acquire time 0s 0% 
INFO - Workflow.ActivityCompleted: Workflow ImportExternal completed in 1s
INFO - Completed Activity 'LevelToFlow' completed in 0s
INFO - Started Activity LevelToFlow
INFO - Completed Activity 'Thresholds' completed in 0s
INFO - EventCrossingModule.Completed: Event crossing module completed
INFO - EventCrossingModule.Started: Event crossing module started
INFO - Started Activity Thresholds
INFO - Completed Activity 'ImportNimrod' completed in 0s
INFO - Started Activity ImportNimrod
INFO - Completed Activity 'ImportTelemetry' completed in 0s
INFO - Started Activity ImportTelemetry
INFO - Workflow.ActivityStarted: Workflow ImportExternal
INFO - TaskRun.Started: Starting Task ImportExternal with ID 3 and T0 2008-10-11 00:00:00 and default forecast length, available memory 405 MB
INFO - ManualForecast.Started: Manual forecast <11-10-2008 00:00:00 ImportExternal> has been sent to the task scheduler


In the table of data display, it show the time steps (GTM). But the values are empty. Please look into attached image.

I followed the steps as exactly mentioned in the exercises. What will cause to this issue ?

Also I noticed that, there is an error in validating
Config/DisplayConfigFiles/ThresholdsDisplay 1.00 default.xml
which begins from line 10,

  <displayDescriptor>
        <forecastTime>
            <columnName>Forecast Time</columnName>
        </forecastTime>
        <thresholdCrossingCountsTab>
            <tabName>Fluvial Crossing Counts</tabName>
            <thresholdGroupId>Fluvial_Flood</thresholdGroupId>
            <relativePeriod unit="day" start="-1" end="0"/>
            <relativePeriod unit="day" start="0" end="1"/>
        </thresholdCrossingCountsTab>
    </displayDescriptor>


In the error description, it mentioned that
cvc-complex-type.2.4.a: Invalid content was found starting with element '{"http://www.wldelft.nl/fews":thresholdCrossingCountsTab}'. One of '{"http://www.wldelft.nl/fews":attributeNoCrossing, "http://www.wldelft.nl/fews":attributeMissingValues, "http://www.wldelft.nl/fews":tab1}' is expected.


How to fix this problem ?

Thank you in advance!
import timeseries exercises
Gihan Karunarathne, modified 1 Year ago.

RE: Import TimeSeries on Exercise 05 not Working for 2014.02 release

Youngling Posts: 2 Join Date: 1/4/17 Recent Posts
Hi Devs,

I tried it out with a Windows Setup. Same issue as above happened. It also give the validation error as well

cvc-complex-type.2.4.a: Invalid content was found starting with element '{"http://www.wldelft.nl/fews":thresholdCrossingCountsTab}'. One of '{"http://www.wldelft.nl/fews":attributeNoCrossing, "http://www.wldelft.nl/fews":attributeMissingValues, "http://www.wldelft.nl/fews":tab1}' is expected.


Do you have any idea about the issue ?
Arnejan van Loenen, modified 1 Year ago.

RE: Import TimeSeries on Exercise 05 not Working for 2014.02 release

Padawan Posts: 70 Join Date: 5/29/12 Recent Posts
Hi Gihan

According to the color of the cross (light red), there are data in the database for the timeserie. But I can imagine it is for a different period than you are currently viewing! There are two things you can do:
- press button with arrows pointing left and right (zoom out to show entire timeseries)
- Press F12 and select database viewer: this is very useful when "debugging". you can see the actual data in the dabase.

As far as I can see the validation error should not be a problem.

Hope this helps you further!

best regards,
Arnejan