Forum

Fixed time zero

TV
Tomáš Vlasák, modified 6 Months ago.

Fixed time zero

Keen Forecaster Posts: 2 Join Date: 9/24/19 Recent Posts
I wonder if there is a way how to fix (make constant) specific Time Zero for specific workflow. I mean only time. The day would be same as system date.  Thank you for reply.
Jhih-Cyuan Shen, modified 6 Months ago.

RE: Fixed time zero

Keen Forecaster Posts: 1 Join Date: 3/24/11 Recent Posts
you could reference the publicwiki.deltares.nl/display/FEWSDOC/global+properties+file
add "T0" in the  "sa_global.properties" file
   T0=28-02-2013 13:00:00

next time you restart the FEWS the T0 will be 28-02-2013 13:00:00
KV
Klaas-Jan van Heeringen, modified 6 Months ago.

RE: Fixed time zero

Keen Forecaster Posts: 2 Join Date: 6/7/12 Recent Posts
Hi Tomáš, you can define a cardinal timestep for this particular workflow in the workflowdescriptors.  For example something like this:
    <workflowDescriptor id="xxx" forecast="false" visible="true">
        <cardinalTimeStep unit="day" divider="1"/>
    </workflowDescriptor>

this should work fine.
Best regards, Klaas-Jan
TV
Tomáš Vlasák, modified 6 Months ago.

RE: Fixed time zero

Keen Forecaster Posts: 2 Join Date: 9/24/19 Recent Posts
Thank you for your help.  If I understand correctly, T0 parameter in sa_global.properties is functional only in case you work in stand-alone mode. Adding cardinal timestep for particular workflow works fine even in operation client mode. However I found out, that when you set cardinal timestep you have no chance to modify T0 manually in some specific situations. But both solutions are worth. Thank you again!  A colleague of mine came with another possible solution. You can deactivate system time updating in Explorer.xml and if you for example need fixed T0 = 7:00, than you have to run FEWS between 7:00 and 8:00 and till the next restart of FEWS, the time remains fixed.<datetime>    <adjustSystemTimeAutomatically>false</adjustSystemTimeAutomatically></datetime>