intro story Coast / Estuary

Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Message Boards

Compilation problem on Ubuntu 18.04 caused by PETSc

JD
Jason Duguay, modified 1 Month ago.

Compilation problem on Ubuntu 18.04 caused by PETSc

Youngling Posts: 1 Join Date: 6/12/19 Recent Posts

Hello,

 

I am trying to compile this version of Delft3D on Ubuntu 18.04:

 

https://svn.oss.deltares.nl/repos/delft3d/tags/delft3d4/62441/

 

I went through and made sure I had all the listed dependencies. Then I proceeded to do the steps for Option 1. However, after running this command:

 

CFLAGS='-O2' CXXFLAGS='-O2' FFLAGS='-O2' FCFLAGS='-O2' ./configure --prefix=`pwd` --with-netcdf --with-mpi --with-metis –with-petsc

 

I keep running into this error:

 

...

...

checking for mpif.h... yes

configure: creating ./config.lt

config.lt: creating libtool

checking for the extension of Delft3D plugins... .so

./configure: line 29905: ACX_MKL: command not found

checking for PETSc... no

configure: error: Package requirements (PETSc < 3.5) were not met:

 

Requested 'PETSc < 3.5' but version of PETSc is 3.7.7

 

Consider adjusting the PKG_CONFIG_PATH environment variable if you

installed software in a non-standard prefix.

 

Alternatively, you may set the environment variables PETSc_CFLAGS

and PETSc_LIBS to avoid the need to call pkg-config.

See the pkg-config man page for more details.

 

 

I tried to get a downgraded version of PETSc with sudo apt-get install petsc-dev, but there only seems to be version 3.7.7 available. I also tried manaully installing an older version of PETSc from their website, however I can’t seem to get over this one. Since PETSc is not listed in the official list of dependancies, I am starting to think that maybe I have gone wrong somewhere in the installation process.

 

Any help in overcoming this problem would be super helpful :)

Adri Mourits, modified 1 Month ago.

RE: Compilation problem on Ubuntu 18.04 caused by PETSc

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts

Hi Jason,

What happens if you exclude PETSc by removing the flag "–with-petsc"? Do you plan to do parallel computations with D-Flow FM using PETSc?

Using the correct version number is indeed very sensitive. The PETSc documentation should clarify them.

As a general advise: Be sure that everything is compiled with the same compiler as you use for the Delf3D code.

 

Regards,

Adri