Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Back

RE: IBotSeg out of range

JC
José Rafael Cavalcanti, modified 9 Days ago.

IBotSeg out of range

Youngling Posts: 16 Join Date: 10/21/18 Recent Posts

Hi,

I am having a problem with WAQ simulations regarding the IBotSeg. As I understood, the bottom segment number is supposed to be calculated from the geometry. However, while trying to perform a WAQ simulation it results on the message showed bellow. Does anyone knows how I can solve this issue? Or at least what is causing it?

Cheers

AM
Arjen Markus, modified 9 Days ago.

RE: IBotSeg out of range

Jedi Knight Posts: 235 Join Date: 1/26/11 Recent Posts

IbotSeg is indeed a quantity that is determined by the process itself (COVMAC). It represents the segment number of the bottom-most segment per column of segments. It is a trifle odd that it throws this error. The simplest solution is to turn off the process in question - unless you are modelling macrophytes you do not need it (it is activated because of a quirk in the process library configuration tool - an unfortunate confusion that is not easily solved, usually harmless, but not in this particular case).

If you do need it, then we will need to examine the model input more closely.

JC
José Rafael Cavalcanti, modified 8 Days ago.

RE: IBotSeg out of range

Youngling Posts: 16 Join Date: 10/21/18 Recent Posts

Hi,

What is the procedure in order to delete it? I am not modeling macrophytes, so I am assuming that PLCT is adding this process automatically.

Cheers

 

AM
Arjen Markus, modified 8 Days ago.

RE: IBotSeg out of range

Jedi Knight Posts: 235 Join Date: 1/26/11 Recent Posts

The .sub file you load in contains a list of processes:

active-processes
   name  'Compos' 'Composition'
   name  'Sed_IM1' 'Sedimentation IM1'

   ...

end-active-processes

It is a simple text file. So with a text editor (not Word, mind you) you can simply remove the process by deleting the line containing "Coverage" (the more meaningful name for COVMAC). These processes turn up in the list of Extra Processes in PLCT.

 

 

JC
José Rafael Cavalcanti, modified 8 Days ago.

RE: IBotSeg out of range

Youngling Posts: 16 Join Date: 10/21/18 Recent Posts

Do I have to change the .0 file as well? I noticed that IBotSeg is also a parameter there.

AM
Arjen Markus, modified 7 Days ago.

RE: IBotSeg out of range

Jedi Knight Posts: 235 Join Date: 1/26/11 Recent Posts

The .0 file is a dump of the internal status of PLCT. It is used to restore a previous session. Do not change it, it is likely to become unuseable and it is not used by any other program. The GUI takes the substances file, .sub. SO all you need to do is change that one.

JC
José Rafael Cavalcanti, modified 6 Days ago.

RE: IBotSeg out of range

Youngling Posts: 16 Join Date: 10/21/18 Recent Posts

Ok. Thanks! It worked fine.