intro story Coast / Estuary

Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Message Boards

Compilation errors with 5.01.00.2163

SD
Steven Douglas, modified 7 Years ago.

Compilation errors with 5.01.00.2163

Youngling Posts: 6 Join Date: 10/22/13 Recent Posts
Hello,

I've just recently came across Delft3D and would like to use it for research purposes. To the best of my knowledge I've followed the compiling instructions included in the download of the soruce code, but yet I have not yet been able to compile it successfully.

I am running Windows (64-bit) and using Visual Studio 2008 with Intel(R) Visual Fortran Compiler XE 14.0.1.139. When I try to build the solution (d_hydro_open_source) it runs for about 15-20 min and finishes with 55 successes and 7 failed.

The fatal error LNK1181 seems to be occuring which fails to open flow2D3D_openda.lib. Also, When I try to run d_hydro.exe it tells me that pthreadVCE2.dll is missing from my computer. Now, I've seen a thread where the original poster solved a similar issue by downgrading to .NET 4.0 framework, but this is already installed on my computer. I have also tried compiling several other versions but the outcome has been similar.

If anyone has any suggestions I would greatly appreciate it.

Steven
SD
Steven Douglas, modified 7 Years ago.

RE: Compilation errors with 5.01.00.2163

Youngling Posts: 6 Join Date: 10/22/13 Recent Posts
I apologize if I did not provide enough information in my original post, but I've been looking into this problem much deeper over the last few days and have seemed to solve my original problem.

It seems that the required Fortran libraries were not linking properly and I would get an error something of the like:

LNK1181 cannot open input file 'objectfilelibraryname.lib'



This was happening for several of the fortran projects like flow2D3D_intel13, flow2D3D_openda_intel13, dat_intel13, kubint_intel13 and lint_intel13. However, the required libraries were installed under the intel fortran compiler directory. For each of the projects listed above, in visual basic I would right click on it > Properties > Linker > Input > Additional Dependencies and added the pathways manually to all the libraries included in the folder.

With this done, I was able to compile the code and run the first example successfully.

I did however have one error left after compiling - "Error 957 ERROR while copying "redist\ia32\compiler\*.dll" to "..\bin\win32\wave\lib"

This didn't seem to stop me from running the example, but I was hoping someone may have insight into what is going with that, and if it will be detrimental later on.

Steven
Adri Mourits, modified 7 Years ago.

RE: Compilation errors with 5.01.00.2163

Yoda Posts: 1212 Join Date: 1/3/11 Recent Posts
Hi Steven,

Good to hear that you are able to compile using Intel14. It's really terrible, all these versions needing different paths.

When a dll/exe is successfully build, an install script is called (...\src\scripts_lgpl\win32\oss-install.cmd) via the post-build mechanism. This script also tries to copy redistributable dlls from the Intel Fortran compiler directory. This copy action goes wrong and causes your error message. To solve this, you have to replace all occurrences of "INTEL_COMPILER13" with "INTEL_COMPILER14", see also this post.

If you don't solve this error, it will work without any problem on your machine, but problems may occur when you try to get it running on another machine.

Regards,

Adri