intro story Coast / Estuary

Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Message Boards

Make fails! Compiling on Linux Ubuntu 18.04.5 LTS

JN
Josias NONGBE, modified 1 Month ago.

Make fails! Compiling on Linux Ubuntu 18.04.5 LTS

Youngling Posts: 2 Join Date: 1/24/20 Recent Posts
Hi, I tried to compile delft3d for the first time on Linux following instructions  of this website 
 https://www.nowacki.org/delft3d_ubuntu_linux_notes.html based on the instrutions of https://oss.deltares.nl/web/delft3d/source-code , but I got a problem at the final (I think ) step of the compilation/compiling , " 20210120.052122 :: Make fails! " , I tried the solution of the first website listed above... And the Make Fails! Is persistent. What can I do? 
Here a copy of my command lines (terminal) 20210120.052119 :: Running make ds-install &> logs/make.log
20210120.052122 :: Make fails!
ben@ben-Latitude-E5540:~$ export MPI_INCLUDE=/usr/include/mpich2
ben@ben-Latitude-E5540:~$ export MPILIBS_ADDITIONAL="-L/usr/lib/mpich2 -lfmpich -lmpich -lmpl"
ben@ben-Latitude-E5540:~$ export MPIFC=/usr/bin/mpif90
ben@ben-Latitude-E5540:~$ 2367/src/build.sh -gnu -64bit
Using GNU compilers in /usr/bin
Current settings:
export ACLOCAL=""
export AUTOMAKE=""
export AUTOHEADER=""
export AUTOCONF=""
export AUTORECONF_FLAGS=""
export LIBTOOLIZE=""
export LDFLAGS=""
export LDFLAGSMT_ADDITIONAL=" "
export LD_LIBRARY_PATH=""
export MPIFC="/opt/mpich2-1.4.1-gcc-4.6.2/bin/mpif90"
export MPI_INCLUDE="/opt/mpich2-1.4.1-gcc-4.6.2/include"
export MPILIBS_ADDITIONAL="-L/opt/mpich2-1.4.1-gcc-4.6.2/lib -lfmpich -lmpich -lmpl"
export PKG_CONFIG_PATH=""
export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin"
20210120.053034 :: Running ./autogen.sh --verbose &> logs/autogen.log
20210120.053050 :: Running CFLAGS='-O2 ' CXXFLAGS='-O2 ' FFLAGS='-O2 ' FCFLAGS='-O2 ' ./configure --
prefix=/home/ben/2367/src &> logs/configure.log
20210120.053111 :: Running make ds-install &> logs/make.log
20210120.053115 :: Make fails!