intro story Coast / Estuary

Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Message Boards

OpenDA EnsKF - Crash Delft3D

MG
Mariangel Garcia, modified 5 Years ago.

OpenDA EnsKF - Crash Delft3D

Youngling Posts: 2 Join Date: 10/3/13 Recent Posts
Hi,

I'm using OpenDA with Delft3D 2D mode with time series boundary conditions. I have only 2 observation location WL and currents, model without DA is stable with 1 minute time step.

I have 15 time series BCs, to perform the assimilation every 30 minutes.

I'm trying to do 15 days simulation, model is crashing with 10, 20 and 30 ensamble I also try to assimilate only one station and it didn't work, so before going further I want to make sure all the setting are correct, I hope you can help me to find out why the model is becoming unstable.

I used the Estuary problem as a template so for the noise configuration file bbStochModelConfig_win32_ifort the setting is like this:


.
.
.
       <vectorSpecification>
        <state>
            <noiseModel>
             <vector id="West1"/>
             <vector id="West2"/>
             <vector id="West3"/>
             <vector id="West4"/>
             <vector id="West5"/>
             <vector id="West6"/>
             <vector id="West7"/>
             <vector id="West8"/>
             <vector id="West9"/>
             <vector id="West10"/>
             <vector id="West11"/>
             <vector id="West12"/>
             <vector id="West13"/>
             <vector id="West14"/>
             <vector id="West15"/>
                <armaModel operation="add">
                    <stdDev value="0.032428488"/>
                    <armaConstant>0.94595947</armaConstant>
                </armaModel>
            </noiseModel>
            <vector id="state"/>
        </state>
        <predictor>
           <vector id="North.waterlevel" sourceVectorId="North.waterlevel"/>
          <vector id="Mouth.waterlevel" sourceVectorId="Mouth.waterlevel"/>

            
        </predictor>
    </vectorSpecification>
            </noiseModel>


and for thed3dModelFactoryConfig_win32_ifort

.
.
.
.
</model>
    <exchangeItems>
        <exchangeItem id="West1" type="bound_hq" />
        <exchangeItem id="West2" type="bound_hq" />
        <exchangeItem id="West3" type="bound_hq" />
        <exchangeItem id="West4" type="bound_hq" />
        <exchangeItem id="West5" type="bound_hq" />
        <exchangeItem id="West6" type="bound_hq" />
        <exchangeItem id="West7" type="bound_hq" />
        <exchangeItem id="West8" type="bound_hq" />
        <exchangeItem id="West9" type="bound_hq" />
        <exchangeItem id="West10" type="bound_hq" />
        <exchangeItem id="West11" type="bound_hq" />
        <exchangeItem id="West12" type="bound_hq" />
        <exchangeItem id="West13" type="bound_hq" />
        <exchangeItem id="West14" type="bound_hq" />
        <exchangeItem id="West15" type="bound_hq" />
       
        <exchangeItem id="North" type="waterlevel" />
        <exchangeItem id="Mouth" type="waterlevel" />
       
    </exchangeItems>


Here some plot from output

https://www.dropbox.com/s/uqc0b1lgsrh7o5f/VelocitiesError.png?dl=0

https://www.dropbox.com/s/20k3mql52edd381/20%20EnsMemebers.png?dl=0

When I checked the output from the GUI seems is adding noise only at the first BC

xi_f_0 (iteration=1):
xi_f_0=
state, State From Black Box Stoch Model Instance - containing:
noise-on-West1-a.o.= 0.057
state[0,0,0,0,0,0,0,0,0,0,...,0,0,0,0,0,0,0,0,0,0]
xi_f_1 (iteration=2):
xi_f_1=
state, State From Black Box Stoch Model Instance - containing:
noise-on-West1-a.o.= 0.04
state[0,0,0,0,0,0,0,0,0,0,...,0,0,0,0,0,0,0,0,0,0]
x_f_central (iteration=3):
x_f_central=
state, State From Black Box Stoch Model Instance - containing:
noise-on-West1-a.o.= 0
state[0,0,0,0,0,0,0,0,0,0,...,0,0,0,0,0,0,0,0,0,0]
analysis_time (iteration=4):
analysis_time= 5.544E4
pred_f_central (iteration=5):
pred_f_central=
predictions - containing:
North.waterlevel= -0.457
Mouth.waterlevel= -0.474


I hope this info is enough to find out what is the problem,

I am doing something wrong or I just have to increase the nr of ensamble to solve this issue?


Best Regards.