intro story Coast / Estuary

Coast / Estuary

Coastal systems are among the most dynamic physical systems on earth and are subject to a large variety of forces. The morphodynamic changes occurring to coastlines worldwide are of great interest and importance. These changes occur as a result of the erosion of sediments, its subsequent transport as bed load or suspended load, and eventual deposition. 
 
Estuaries are partly enclosed water bodies that have an open connection to the coast. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes. Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter).
Within the Delft3D modelling package a large variation of coastal and estuarine physical and chemical processes can be simulated. These include waves, tidal propagation, wind- or wave-induced water level setup, flow induced by salinity or temperature gradients, sand and mud transport, water quality and changing bathymetry (morphology). Delft3D can also be used operationally e.g. storm, surge and algal bloom forecasting. 
 
On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM. 
 

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 

 

Message Boards

RE: RGFGRID/QUICKIN did not start (DLL path problem)

U
Daijiro Kobashi, modified 8 Years ago.

RGFGRID/QUICKIN did not start (DLL path problem)

Dear all,

I installed Delft3D GUI on my Linux computer (Mint Linux 13) and I think the installation was successful.
However, when I tried out RGFGRID and QUICKIN, I had a problem.
When I clicked "Grid" button under main menu and tried to start RGFGRID, it did not start. Instead I got the following error.

Could not load a DLL,
DLL name = /opt/delft3d/inttel/plugins/bin/librgfgrid.so
Please check the plugins directory and the path environment variable.

(Please check the DLL path carefully).

The same error occurred for QUICKIN too.
There are actually librgfgrid.so and libquickin.so in /opt/delft3d/intel/plugins/bin
The problem was I think that the DLL path was wrong for both RGFGRID and QUICKIN.
The above DLL path should be /opt/delft3d/intel/plugins/bin/librgfgrid.so, not /opt/delft3d/inttel/plugins/bin/librgfgrid.so. This is not a typo. I attach a couple of screenshots as evidence.
A strange thing is this wrong DLL path seem to change every time I click it to load.
Sometime it was /ot/delft3d/inttel/plugins/bin/librgfgrid.so (see an attached screenshot).

I wonder if someone had such a problem or knows how to fix it.

Thanks in advance.

Sincerely,

DJ
U
Sérgio Larangeiro, modified 8 Years ago.

RE: RGFGRID/QUICKIN did not start (DLL path problem)

I’m also using Ubuntu 12.04 and also faced the same problem. I tried to use fedora 17 but the same thing happened again. So I tried doing something to solve the problem. Taking in account previous posts, I opened the file:

/opt/delft3d/intel/menu/default/d3d_menu.ux

and inspecting it, I got the idea of putting more spaces (.....................) between the two sentences of the commands, maintaining both sentences in the same line:

command "$D3D_HOME/$ARCH/plugins/bin/mfe_app.......................................$D3D_HOME/$ARCH/plugins/bin/librgfgrid.so rgfgrid"

command "$D3D_HOME/$ARCH/plugins/bin/mfe_app...................................... $D3D_HOME/$ARCH/plugins/bin/libquickin.so quickin"

Then I saved the file and opened the denft3d-menu and this time both RGFGRIG and QUICKIN options worked fine, lunching the application Delft3D-QUICKIN.

I don’t know if this is the definite solution of this problem, but it works for me, so I hope that this information could be helpful for everyone.

Best regards,
Sérgio Larangeiro
U
Daijiro Kobashi, modified 8 Years ago.

RE: RGFGRID/QUICKIN did not start (DLL path problem) (Answer)

Many thanks, Sergio. I followed your instruction and it has worked for me too.
AA
Anonymous Anonymous, modified 7 Years ago.

RE: RGFGRID/QUICKIN did not start (DLL path problem)

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Definitely works for me - thank you a lot I was close to giving up ;)

Regards,

Oliver