null

Message Boards

RE: Error reading grid file on Linux

FT
francisco tiano, modified 8 Years ago.

Error reading grid file on Linux

Youngling Posts: 1 Join Date: 2/7/12 Recent Posts
Greetings to all ... I installed the free version for linux openhydromorpho graphical environment, but after generating the grid files for the simulation, while I'm trying to run flow, it throws an error reading the grid, this happens with the grid files that I made and also with the grid files that come along with the .deb package in the examples and tutorials ....

The error message only say this:

# Error reading grid file

# /opt/delft3d/doc/tutorial/flow/f34_demo/fti_02.grd


Can anyone help me?

kind regards...
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
I encounter the same problem.

Any updates on that issue?

Regards,


Oliver
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux | Total layer thickness does not equal

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
See attached png's for details,

note that I have also tried to open other .grd files which always resulted in the same error
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux | Total layer thickness does not equal

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Moreover, the RGFGRID readily opens the fti_02.grd file (see png)
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux | Total layer thickness does not equal

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Okay,

found another thread upon this suggesting to replace all decimal "." by "," which I did.

Then the file is read in, however the GUI brings up multiple errors with related parameter files which are all invalid. Nevertheless, the file is loaded and can be viewed and edited.

Regards,

Oliver
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux | Total layer thickness does not equal

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Now,

if one replaces the "." by "," the files can be read and edited with FLOW or WAVE.
However, this renders them inaccessible to RGFGRID, which needs the decimal point instead of the comma.

Is this system related or can I change the DELFT3D settings on this somewhere?
Clearly this is not as it should be?

Regards,

Oliver
FM
florian MONETTI, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 21 Join Date: 3/12/13 Recent Posts
Hi,

I work also with linux and because I had a lot of problems with the GUI in linux, I changed to a Windows Virtual box.
Now I use the GUI in windows and run the model in Linux what's simplier...
I suggest you to done the same in order to resolve this king of errors...

Regards,

Florian
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Hi Florian,

thanks for the hint, guess I'll give it a try. Where does the VMBox need to go? On the servers or on the local machine? And what about the license manager? Is that still neccessary with Win. ?

Cheers,

Oliver
FM
florian MONETTI, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 21 Join Date: 3/12/13 Recent Posts
Hi Oliver,

Put the VMBOX on your local machine and the linux source code on the servers.
There is only one thing to check is the paths of the MDF files.

When you save your MDF file, change the paths with "\" (WIndows) to "/" (Linux).

Let me know the result.

Regards,

Florian
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Hi Florian,


I installed a VMBox and a Windows 7 Pro 64bit onto it.

But the installation of the License Manager does not work? No matter which option I go for it tells me that my machine is not suitable for parallel dongle drives and that these will not be installed (see png).
FM
florian MONETTI, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 21 Join Date: 3/12/13 Recent Posts
Hi Oliver,

I didn't have this problem.
Maybe because of the version you have.
I think you can ask to the Delft team in order to get a valid license for your Windows system.
It's what I did.

Send an email to get the Delft3d GUI for a Window system.

Regards,

Florian
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Hi Florian,

I finally managed it to FUSE the local computer and a folder on the server. The folder can also be accessed by the VBox Windows 7 64bit.

Any further remarks or is this the way you hooked it up too?

How do you get the binaries to run your cases? Did you hook up the whole binaries directory on the server?

Kind regards,



Oliver
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Dear Florian,

I have Linux Binaries on the server and a Windows GUI in the VmBox on the local PC.

I created a first trial model with all necessary input. But when I try to run it from the GUI, Delft searches for the hydro.exe on drive C in the GUI installation path.
Of course these are not there. How did you solve this?

Did you simply copy the .mdf file onto the server and created the .ini and run_.sh files yourself?


Regards,


Oliver
FM
florian MONETTI, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 21 Join Date: 3/12/13 Recent Posts
Hi Oliver,

I created all input files with DELFT GUI on virtual box (windows 64 bits) and my own .ini and .sh from linux (like tutorials on linux).
Just be carefull with the paths (''/'' and ''\'').

You can't run the model from the Virtual Box.
You have to run it from linux.
Just use the GUI for generate input files.

Regards

Florian
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Hi Florian,

I just installed the GUI on Linux as well - used sshsf to share a folder from my local machine with the server and created the files on Windows GUI, accessed them with the Linux GUI and ran the model no problem.

Only, I just had it running on one core - do I need do decompose the domain in order for it to run on multiple cores?


Cheers,


Oliver
FM
florian MONETTI, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 21 Join Date: 3/12/13 Recent Posts
Hi Oliver,

I didn't used the decomposition for the moment.
I have to check that.
I'm working on another thing for the moment.

If you try it, I would like to have a feedback please.

Regards,

Florian
Adri Mourits, modified 7 Years ago.

RE: Error reading grid file on Linux

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Guys,

You can not run a parallel computation (using MPI) via the GUI. You have to write a shell script yourself. See the "...\examples\01_standard" in the source code as an example.

Note that "DomainDecomposition" and "parallel computation with MPI" are two different things that can not be combined in one model. See the FAQ for more info.

Regards,

Adri
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error reading grid file on Linux

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Thanks for the info Adri,


works fine in parallel as well.


Regards,


Oliver
AA
Anonymous Anonymous, modified 7 Years ago.

Error starting Model

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Okay, I might have been a bit quick - I had it running and for some reason it does not want to start now.
I have attached the model files - maybe somebody gets it to run? I ran before and I do not know why it does not now.


If I try executing it manually by copying it into the examples folder and adapting the runid and the config file I get:

lojek@ws17:~/Delft_Flow/examples/Model_1_Coarse$ ./run_flow2d3d.sh
Executing "/home/lojek/Delft_Flow/bin/lnx/flow2d3d/bin/d_hydro.exe TMP_config_flow2d3d_31494.xml" ...
--------------------------------------------------------------------------------
       Deltares, FLOW2D3D Version 5.01.00.2691, Jul  8 2013, 14:24:22
       libflow2d3d.so entry Flow2D3D::Run
--------------------------------------------------------------------------------

Part I    - Initialisation Time Dep. Data module...   
            runid : Model_1
Part II   - Creating intermediate files...            
ABORT: error returned by tdatmain
Flow exited abnormally


ERROR: child process exited abnormally
       - Starting "d_hydro.exe" may give more information:
         - Run "deltares_hydro.exe <INI-inputfile> -keepXML".
         - Run "d_hydro.exe TMP_config_flow2d3d_<processId>.xml".
lojek@ws17:~/Delft_Flow/examples/Model_1_Coarse$



If I try to start it via the Linux GUI i get the error in the attached PNG.
Which seems queer since the lib2d3d.so is located in the same PATH as the d_hydro.exe?

Has someone encountered this before?




Regards,

Oliver
AA
Anonymous Anonymous, modified 7 Years ago.

RE: Error starting Model

Jedi Master Posts: 333 Join Date: 7/30/20 Recent Posts
Okay - found out I had to copy the libflow2d3d.so into the /plugins/bin directory for the GUI to get it.

Then the calculation started and told me via the "diag" file that a process time was too long compared to the overall runtime of the model and I fixed it.

Great tool if you know where to look for errors.


Sorry for the trouble,


Oliver
JM
Jan Mooiman, modified 7 Years ago.

RE: Error reading grid file on Linux

Youngling Posts: 14 Join Date: 1/7/11 Recent Posts
We will investigate the problem (support@deltares.nl) , because it should not be there. If a work around is available then I will post it here.

Regards Jan Mooiman