intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

libmpifort.so.12 error when running example 1

SB
Selwyn Bergman, modified 3 Years ago.

libmpifort.so.12 error when running example 1

Youngling Posts: 8 Join Date: 5/20/13 Recent Posts
Hello,

I have come across an error when trying to setup a D3D modelling setup for a colleague. I have managed to download and compile the binaries, but when I try to run example 1, I get the following error:

lau@model-D3D:~/Deltares/delft3dtrunk/examples/01_standard$ ./run_flow2d3d.sh
d_hydro ABORT: Cannot load component library "/home/lau/Deltares/delft3dtrunk/bin/lnx64/flow2d3d/bin/libflow2d3d.so": libmpifort.so.12: cannot open shared object file: No such file or directory


I've had a look around and found the file (libmpifort.so.12) located underneath the prefix where I installed mpich, and can also find the file libflow2d3d.so underneath the bin folder for flow2d3d. So everything seems to be where it should be, but I am still getting the error.

Can anyone please assist?

Thanks
- Selwyn
Qinghua Ye, modified 3 Years ago.

RE: libmpifort.so.12 error when running example 1

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi Selwyn,

It is most probably because of the path. Would you try to set LD_LIBRARY_PATH, by adding the MPI library path?

By the way, how did you install MPICH there? by downloading the code and compiled yourself or by downloading the dll directly?

Best Regards,

Qinghua
SB
Selwyn Bergman, modified 3 Years ago.

RE: libmpifort.so.12 error when running example 1

Youngling Posts: 8 Join Date: 5/20/13 Recent Posts
Hi Qinghua,

It looks like this problem is solved now. For the archive, I did a

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/user/path_to_mpich_libraries


and then reran the example, and it worked.

I also downloaded and compiled the code myself for mpich.


Thanks for your help.
- Selwyn