intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

error at make

DA
Drew Ackerman, modified 8 Years ago.

error at make

Youngling Posts: 6 Join Date: 4/5/12 Recent Posts
I am working on installing the Flow3d on a virtual VMWare 32-bit Ubuntu 11.10system. I have been following the steps outlined in 'How to compile Delft3D under Linux' and think that I have all the required programs installed but can't get past the "make". The final portion of the make output is below showing the error that stops it. It appears that there is an error with gfortran (I'm using version 4.6.1) but I'm not sure where thing are going sideways. Has anyone run into this type of error before?

I have attached the config.log file but don't see a make.log file

Thanks
Drew


make[7]: Entering directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d/packages/data/src/parallel_mpi'
/bin/bash ../../../../../../libtool --tag=FC --mode=compile mpif90 -DHAVE_CONFIG_H -I. -I../../../../../.. -I -I../../../../../../utils_lgpl/parallel_mpi/include -I../../../../../../utils_lgpl/precision/include -I../../../../../../engines_gpl/flow2d3d/packages/data/include -I../../../../../../utils_lgpl/precision/packages/precision/src -I../../../../../../engines_gpl/flow2d3d/packages/data/src/parallel_mpi -I../../../../../../engines_gpl/flow2d3d/packages/data/src/basics -I../../../../../../utils_lgpl/ec_module/packages/ec_module/src -I../../../../../../utils_lgpl/inifiles/packages/inifiles/src -I../../../../../../utils_lgpl/deltares_common/packages/deltares_common/src -DDFMPI -g -fopenmp -fpp -recursive -reentrancy threaded -traceback -c -o dfparall.lo dfparall.F90
libtool: compile: mpif90 -DHAVE_CONFIG_H -I. -I../../../../../.. -I -I../../../../../../utils_lgpl/parallel_mpi/include -I../../../../../../utils_lgpl/precision/include -I../../../../../../engines_gpl/flow2d3d/packages/data/include -I../../../../../../utils_lgpl/precision/packages/precision/src -I../../../../../../engines_gpl/flow2d3d/packages/data/src/parallel_mpi -I../../../../../../engines_gpl/flow2d3d/packages/data/src/basics -I../../../../../../utils_lgpl/ec_module/packages/ec_module/src -I../../../../../../utils_lgpl/inifiles/packages/inifiles/src -I../../../../../../utils_lgpl/deltares_common/packages/deltares_common/src -DDFMPI -g -fopenmp -fpp -recursive -reentrancy threaded -traceback -c dfparall.F90 -fPIC -o .libs/dfparall.o
gfortran: error: threaded: No such file or directory
gfortran: error: unrecognized option '-recursive'
gfortran: error: unrecognized option '-reentrancy'
gfortran: error: unrecognized option '-traceback'
make[7]: *** [dfparall.lo] Error 1
make[7]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d/packages/data/src/parallel_mpi'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d/packages/data/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d/packages/data'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d/packages'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl/flow2d3d'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/drew/delft3dtrunk/src/engines_gpl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/drew/delft3dtrunk/src'
make: *** [all] Error 2
Adri Mourits, modified 8 Years ago.

RE: error at make

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Drew,

gfortran does not recognize some flags.

I assume you used a tagged version (which is good as a start)? I expect this problem to be solved in the current trunk, revision 1427. This revision is stable for more than 90%. Can you give it a try?

Regards,

Adri
AB
Adriano Barroso, modified 7 Years ago.

RE: error at make

Youngling Posts: 0 Join Date: 8/19/12 Recent Posts
Hi Adri,

I'm trying to compile Delft3d. However, like Drew, I'm having some problems at the same point. I'm using Ubuntu 12.04LTS.

I tried to change the fortran compiler in mpif90 to ifort, but the problem still happening.

Thanks in advance.

Cheers