intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

d_hydro.exe stopped working

Fernando Barreto, modified 7 Years ago.

d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
I I compiled successfully tag 1234, and all executables and lib were generated (windows 7, MVS 2010, intel composer 11.1, release) ; butwhen I try to execute the 01_standard file run_flow2d3d.bat, it execute until 97.7%, but than appers a windows ''d_hydro.exe stopped working'', and in DOS appers:

- Starting "d_hydro.exe" may give more information:
- Run "deltares_hydro.exe <INI-inputfile> -keepXML".
- Run "d_hydro.exe TMP_config_flow2d3d_<processId>.xml.
.

When I try to execute bin/d_hydro.exe it executes, but deltares_hydro.exe don't.


The same thing happens with other tags. The config file is in example directory.


Att. Fernando
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi, Fernando,

Would you also paste the content of the tri-diag file as well?

Based on the information you pasted, we cannot say what happened.

Regards,

Qinghua
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
tri-dialog.f34 ? It's a huge file.
Another thing, I converted win 32, with convert_win32_to_old_directory_structure_w32 (iI changed w32 to win32), because without it d_hydro.exe didn't run (it asked a lib file); so I think that d_hydro.exe run now (afeter convert, it don't' ask for a lib fie). However deltares_hydro gives error (I can see queekly in DOS).
What is INI-input file?, is it used by deltares_hydro?
Thanks
Fernando
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi Fernando,

I mean the suspecious content in the tri-diag files. Should be not all of the huge file.

You are right that the convert_win32_to_old_directory_structure_w32 batch file will change the dir structure. However, my suggestion is to compile the latest version again to avoid the structure problem.

In the new structure, deltares_hydro will use the ini file to generate a xml file, which is used by d_hydro.exe.

If you follow the examples with the source code, your project should work as well.

Just my opinion, for your reference.

Regards,

Qinghua
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
But there is no ini file (config_flow2d3d) in 1677/bin/win32/flow2d3d/bin for deltares_hydro. Are the ini files in the examples all right, or do I need to modify something for my own?
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi, Fernando,

The ini file (config_flow2d3d) is in your own running directory (the same directory as mdf file). You may check the file, whether the mdf filename is correct or not. I don't think you have to change anything else in the ini file. But make sure the run batch file is correct.

Hope this helps,

Qinghua
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
unfortunately When I run deltares_hydro.exe in C:\1677\bin\win32\flow2d3d\bin directory it gives a error: '':error start deltares_hydro with 1 or 2 arguments. usage: <config.ini> keep xml.''
What this mean? How do I generate this XML file. Must the config_flow2d3d.ini be in the bin directory, or only in the example directory.

Maybe this is the cause of the d_hydro.exe to stop running.
This is the ini file (config_flow2d3d.ini) that I use, it's in the example (C:\1677\examples\01_standard\) and in the bin directories:

[FileInformation]
FileCreatedBy = runtestbank Tcl scripts
FileCreationDate = Mon Dec 06 2:55:54 PM W. Europe Standard Time 2010
FileVersion = 00.01
[Component]
Name = flow2d3d
MdfFile = f34


Thank you and sorry for the inconvenience
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
The TMP_config_flow2d3d_2088.xml file is been generated in the example_01 directory, it should have been generated in the bin directoy, or not?

This is the TMP_config_flow2d3d_2088.xml file, located in the C:\1677\examples\01_standard\TMP_config_flow2d3d_2088.xml directory:

<?xml version="1.0" encoding="ISO-8859-1"?>

<!-- This file is generated by: -->

<!-- deltares_hydro.exe/deltares_hydro.tcl version 4.99.02 -->

<!-- emulator for running Delft3D-FLOW version 5.xx (d_hydro.exe) -->
-<DeltaresHydro start="flow2d3d"> <flow2d3d description="Delft3D-FLOW single domain calculation" MDFile="f34" library="flow2d3d"> </flow2d3d> </DeltaresHydro>
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi, Fernando,

The command should be: deltares_hydro.exe <INI-inputfile> -keepXML.

I don't know exactly what the problem is in your environment. You know that everytime before we release to the open source system, all the examples and another hundreds cases in our testbank should pass.

So I guess it must be a problem of structure of the directory in your environment. Could you double check again?

When you download the source code with the examples, the structure is set ok, I think.

Then, just compile the code in release mode, and run the batch files in the examples folders. It should work like that.

Regards,

Qinghua
Mladen Radovanovic, modified 7 Years ago.

RE: d_hydro.exe stopped working

Youngling Posts: 10 Join Date: 6/10/12 Recent Posts
Dear,

I have exactly the same problem. (VS2010 & Intel(R) Visual Fortran Compiler XE on IA-32, version 12.1.5)

I had tried everything you advised but no results. Computation stops at 97.3% or something like that. Moreover, I have tried with release and debug version... nothing.

6 errors during compiling occur

Error 100 error RC2104: undefined keyword or key name: Unversio d:\delft3d_compiled\src\utils_lgpl\nefis\packages\nefis_version_number\include\version_number.rc 31
Error 102 error RC2104 : undefined keyword or key name: Unversio d:\delft3d_compiled\src\tools_gpl\mormerge\packages\mormerge_version_number\include\version_number.rc 31
Error 106 error RC2104: undefined keyword or key name: Unversio d:\delft3d_compiled\src\tools_gpl\vs\packages\vs_version_number\include\version_number.rc 31
Error 107 error RC2104: undefined keyword or key name: Unversio d:\delft3d_compiled\src\tools_gpl\lint\packages\lint_version_number\include\version_number.rc 31
Error 108 error RC2104: undefined keyword or key name: Unversio d:\delft3d_compiled\src\tools_gpl\kubint\packages\kubint_version_number\include\version_number.rc 31
Error 116 error RC2104: undefined keyword or key name: Unversio d:\delft3d_compiled\src\tools_gpl\datsel\packages\datsel_version_number\include\version_number.rc 31

my tri-diag file is attached

Please help

Kind regards,

Mladen
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working (Answer)

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Dear Mladen,

The formal compiling was fully tested with the compiler of Visual Studio 2008, with intel composer 11.1, release (refer to http://oss.deltares.nl/web/opendelft3d/source-code#prerequisites)

I realized that your compiling is using VS2010 & Intel(R) Visual Fortran Compiler XE on IA-32, version 12.1.5 and Fernando was using VS 2010, intel composer 11.1. We need some time to verify these settings.

Regards,

Qinghua
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
I will isntall in my computer MVS 2008. Do you also use this version?

Thanks
Qinghua Ye, modified 7 Years ago.

RE: d_hydro.exe stopped working

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi Fernando,

we have these environments, but the formal compiling was fully tested with the compiler of Visual Studio 2008, with intel composer 11.1, release (refer to http://oss.deltares.nl/web/opendelft3d/source-code#prerequisites).

Regards,

Qinghua
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working (Answer)

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
I installed MVS 2008, and the example runned.

thanks
Fernando Barreto, modified 7 Years ago.

RE: d_hydro.exe stopped working

Padawan Posts: 74 Join Date: 6/21/12 Recent Posts
The example ran