intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Error compiling on ubuntu 12.04 LTS 32b

SI
Sasha Izru, modified 8 Years ago.

Error compiling on ubuntu 12.04 LTS 32b

Youngling Posts: 20 Join Date: 9/16/12 Recent Posts
Hi everyone!

I'm newbie in Delft 3D and I'm trying to compile it on Ubuntu 12.04 LTD (32bits).
I have followed all the recommendations that were mentioned in the screencast and presentation "How to compile Delft3D under Linux".
I installed all the libraries Delft 3d needs (I think, that):
autoconf, libtool, flex, gfortran, mpich2, g++, gcc, libexpat1, libexpat1-dev, tcl, byacc-j, expat, pthread, bison, xorg-dev, libltdl-dev, libreadline6-dev.

I didn't have any problem with: ./autogen.sh

In order to configure Delft, I used:
./configure --prefix=$(pwd)/build
Everything fine with configure.

Later, I did the next step:
make ds-install
But...
At the end of process of make, I got this (I only last lines in this post):

g++ -DHAVE_CONFIG_H -I. -I../../../../.. -I-I../../../../../engines_gpl/d_hydro/include -I../../../../../engines_gpl/flow2d3d/packages/flow2d3d/include -I../../../../../utils_lgpl/d_hydro_lib/include -I../../../../../utils_lgpl/delftonline/include -I../../../../../utils_lgpl/esmfsm/include -I../../../../../utils_lgpl/precision/include -I../../../../../utils_lgpl/stream/include -I../include -D_GNU_SOURCE -DSTR_LEN_AT_END -DWITH_DELFTONLINE -pthread -g -O2 -MT d_hydro.o -MD -MP -MF .deps/d_hydro.Tpo -c -o d_hydro.o d_hydro.cpp
d_hydro.cpp: In constructor ‘DeltaresHydro:emoticoneltaresHydro(int, char**, char**)’:
d_hydro.cpp:148:37: error: ‘_strdup’ was not declared in this scope
d_hydro.cpp:187:47: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
make[6]: *** [d_hydro.o] Error 1
make[6]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl/d_hydro/packages/d_hydro/src'
make[5]: *** [install] Error 2
make[5]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl/d_hydro/packages/d_hydro/src'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl/d_hydro/packages/d_hydro'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl/d_hydro/packages'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl/d_hydro'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/gar/Programas/Delft3d/delft/src/engines_gpl'
make: *** [install-recursive] Error 1

I don't have any idea in order to fix this error.
Please, may anyone help me, with this problem?

Thanks!

Sasha
Adri Mourits, modified 8 Years ago.

RE: Error compiling on ubuntu 12.04 LTS 32b

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Sasha,

I introduced this error in revision 1848 (Friday 14th September) of the trunk. It is solved in revision 1851 (Tuesday 18th September).

To avoid these kind of problems, you can start with the latest fully tested stable version (currently https://svn.oss.deltares.nl/repos/delft3d/tags/5.00.07.1698) instead of the trunk version.

Regards,

Adri
SI
Sasha Izru, modified 8 Years ago.

RE: Error compiling on ubuntu 12.04 LTS 32b

Youngling Posts: 20 Join Date: 9/16/12 Recent Posts
Hi Adri,

Thank you for your reply.

I downloaded the new stable version and I did the same compiling process:
./autobash.sh
./configure --prefix=$(pwd)/build
make ds-install

Finally, I got the deltares_hydro.tcl file.

I think it was solved my problem.

Thanks, again, Adri!


Regards.



Sasha