intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Compiling in Ubuntu 12.10 64-bit

MS
Mihael Souza, modified 8 Years ago.

Compiling in Ubuntu 12.10 64-bit

Padawan Posts: 65 Join Date: 10/11/12 Recent Posts
Hi everyone,

First of all, sorry for any dumb questions or doubts I might be asking.
Just started using linux (3 days ago) and still it's all very new to me.
Trying to migrate between OS (windows - linux) to avoid proprietary software issues.

I'm trying to install Delft 3D, but I keep getting to the same error.
I'm using the last tagged version available at the source, and have all the pre-requisites done (followed the webinar on compiling in linux)
I've searched through the other threads, and I found a similar error, but did not understood the resolution (sorry about that).

I have tried both methods in the README file

./build.sh -gnu -64bit

error obtained: Make fails!

and

./autogen.sh
./configure --prefix=`pwd`
make ds-install

error obtained:
/usr/bin/ld: ../../../../../utils_lgpl/inifiles/packages/inifiles/src/libinifiles.a(inifiles_version.o): relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
../../../../../utils_lgpl/inifiles/packages/inifiles/src/libinifiles.a: could not read symbols: Bad value
collect2: error: ld returned 1 exit status
make[5]: ** [libtrisim.la] Erro 1
make[5]: Saindo do diretório `/home/mihael/delft3d_repository/src/engines_gpl/flow2d3d/packages/manager/src'
make[4]: ** [install-recursive] Erro 1
make[4]: Saindo do diretório `/home/mihael/delft3d_repository/src/engines_gpl/flow2d3d/packages/manager'
make[3]: ** [install-recursive] Erro 1
make[3]: Saindo do diretório `/home/mihael/delft3d_repository/src/engines_gpl/flow2d3d/packages'
make[2]: ** [install-recursive] Erro 1
make[2]: Saindo do diretório `/home/mihael/delft3d_repository/src/engines_gpl/flow2d3d'
make[1]: ** [install-recursive] Erro 1
make[1]: Saindo do diretório `/home/mihael/delft3d_repository/src/engines_gpl'
make: ** [install-recursive] Erro 1

Also tried downloading the latest trunk version, but no success there too.
Any ideas?

I have attached the log file, case it can shed some light.

Attachments:

MS
Mihael Souza, modified 8 Years ago.

RE: Compiling in Ubuntu 12.10 64-bit

Padawan Posts: 65 Join Date: 10/11/12 Recent Posts
Well, finally was able to compile and install it successfully.
Like I imagined, it was a noobish mistake, with me not knowing how to set PATH files correctly.

If anyone else reached the same problem, the answer that worked for me can be found here:
http://oss.deltares.nl/web/opendelft3d/general/-/message_boards/view_message/160070

By making the alterations suggested by João Silva in the build.sh file, I was able to build it successfully.
MS
Mihael Souza, modified 8 Years ago.

RE: Compiling in Ubuntu 12.10 64-bit

Padawan Posts: 65 Join Date: 10/11/12 Recent Posts
Ok, looks like I still need some help.

Although the above fix did allowed me to install Delft 3D, it appears to not be running.
./build.sh -gnu -64bit as finished. I got the positive message as a response.
But when I ran an example, the 01 in the examples folder, nothing happened.
Since no error message appeared, I thought all was good.

But, whenever I try, for example, to run example 03, regarding waves, it stops in the "Awaiting for FLOW module"
It seems that flow is not running properly.
I checked the binaries folder, an d_hydro.exe, deltares_hydro.exe and lib_flow2d3d.so were all built.
Don't know what's going on.

Any thoughts?
Adri Mourits, modified 8 Years ago.

RE: Compiling in Ubuntu 12.10 64-bit

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Mihael,

I added "run_flow2d3d_xml.sh" in example 01 (in the trunk version, revision 1926). Can you try running that?
I expect that you have problems running "deltares_hydro.exe" on your machine. This is a tiny executable, converting the config.ini file into a config.xml file and executing "d_hydro.exe".

The format of the xml file will change, hopefully within a month. When it has it's final shape, "deltares_hydro.exe" will be completely removed. Be aware that the current GUI only accepts ini files.

Regards,

Adri