intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Compilation problem on Ubuntu 18.04 caused by PETSc

JD
Jason Duguay, modified 8 Months ago.

Compilation problem on Ubuntu 18.04 caused by PETSc

Youngling Posts: 1 Join Date: 6/12/19 Recent Posts

Hello,

 

I am trying to compile this version of Delft3D on Ubuntu 18.04:

 

https://svn.oss.deltares.nl/repos/delft3d/tags/delft3d4/62441/

 

I went through and made sure I had all the listed dependencies. Then I proceeded to do the steps for Option 1. However, after running this command:

 

CFLAGS='-O2' CXXFLAGS='-O2' FFLAGS='-O2' FCFLAGS='-O2' ./configure --prefix=`pwd` --with-netcdf --with-mpi --with-metis –with-petsc

 

I keep running into this error:

 

...

...

checking for mpif.h... yes

configure: creating ./config.lt

config.lt: creating libtool

checking for the extension of Delft3D plugins... .so

./configure: line 29905: ACX_MKL: command not found

checking for PETSc... no

configure: error: Package requirements (PETSc < 3.5) were not met:

 

Requested 'PETSc < 3.5' but version of PETSc is 3.7.7

 

Consider adjusting the PKG_CONFIG_PATH environment variable if you

installed software in a non-standard prefix.

 

Alternatively, you may set the environment variables PETSc_CFLAGS

and PETSc_LIBS to avoid the need to call pkg-config.

See the pkg-config man page for more details.

 

 

I tried to get a downgraded version of PETSc with sudo apt-get install petsc-dev, but there only seems to be version 3.7.7 available. I also tried manaully installing an older version of PETSc from their website, however I can’t seem to get over this one. Since PETSc is not listed in the official list of dependancies, I am starting to think that maybe I have gone wrong somewhere in the installation process.

 

Any help in overcoming this problem would be super helpful :)

Adri Mourits, modified 8 Months ago.

RE: Compilation problem on Ubuntu 18.04 caused by PETSc

Yoda Posts: 1224 Join Date: 1/3/11 Recent Posts

Hi Jason,

What happens if you exclude PETSc by removing the flag "–with-petsc"? Do you plan to do parallel computations with D-Flow FM using PETSc?

Using the correct version number is indeed very sensitive. The PETSc documentation should clarify them.

As a general advise: Be sure that everything is compiled with the same compiler as you use for the Delf3D code.

 

Regards,

Adri