intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

System cannot find the file

NP
Nuria Perez Luis, modified 7 Years ago.

System cannot find the file

Youngling Posts: 2 Join Date: 1/9/13 Recent Posts
Hi friends,

When I try to open the file "d_hydro_open_source_2010_vs2010" in VS get the following error:

<Cannot start the program 'c:/delft3d_repository/src/utils_lgpl/esmfsm/packages/esmfsm_c/bin/Debug/esmfsm_c.lib'. The system cannot find the file specified.>

Someone can help me, please?? I installed on my window XP (32 bit) program Visual Studio 2010 Professional, Intel Paralell Virtual Studio XE11 and Intel Visual Fortran Composer 11.

Best regards ! Thanks for all
Adri Mourits, modified 7 Years ago.

RE: System cannot find the file

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Nuria,

Currently we are reorganising the code structure a bit in the trunk version. It's getting close to being solved. If you do an SVN update, the problem might be solved.
If not or if you want to be safe, please use the latest tagged version.

Regards,

Adri
NB
Nophi Biton, modified 7 Years ago.

RE: System cannot find the file

Padawan Posts: 38 Join Date: 8/1/13 Recent Posts
Hi,

my colleague is also trying to compile d3d, she also encounters this problem, she uses the tagged version /2869.

she uses MS VS 2012 and intel compiler XE 2013 (trial version). how can this be solved?? Does an update to the latest trunk version advisable for this?



Regards
Nophi
Adri Mourits, modified 7 Years ago.

RE: System cannot find the file

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Nophi,

When using VS2012 with Intel 2013, you certainly must update to the version tagged Today: 3008.

Regards,

Adri