intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Problems with Real Time Control (missing DLL's when running rtc.exe)

AK
Aline Kaji, modified 6 Months ago.

Problems with Real Time Control (missing DLL's when running rtc.exe)

Youngling Posts: 1 Join Date: 3/13/12 Recent Posts
I am having issues running the Real Time Control with Delft3D-FLOW. I have followed the instructions in the Delft3D-FLOW manual and also tried to run the example posted in this thread: https://oss.deltares.nl/web/delft3d/home/-/message_boards/message/300100/maximized#_com_liferay_message_boards_web_portlet_MBPortlet_message_300100

Delft3D-FLOW starts without problems (and waits for RTC initialization), when I try to run rtc.exe I get some errors of missing dlls:- libifportMD.dll- libifcoremd.dll- libmmd.dll
I found these missing dlls in other folders of the Delft3D, but I believe they are not the same as the ones required by RTC.I tried copying the dlls to the folder where rtc.exe is but still no success.
Any suggestions?
Is there a especial compilation step for the rtc? Or the normal Delft3D compilation should work?All these tests were done in a Windows 10.
And lastly, I was wondering if Delft3D-FLOW + RTC also works in Linux
LE
lerneini edstein, modified 2 Months ago.

RE: Problems with Real Time Control (missing DLL's when running rtc.exe)

Youngling Posts: 2 Join Date: 12/19/19 Recent Posts
<p>I have also faced the similar issue.</p>