intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Delft3d Compilation Error | MPI 1.4.1

AA
Anonymous Anonymous, modified 7 Years ago.

Delft3d Compilation Error | MPI 1.4.1

Padawan Posts: 75 Join Date: 7/30/20 Recent Posts
Hi,

having downloaded the Delft3d source code and GUI I ran into several problems while compiling;
currently I am facing a problem with the MPI during the compilation of Delft3d:

A search on the forum did not reveal a solution, a webbased search revealed a thread in a ubuntu forum which seemed to address the problem.

However, it did not remedy the problem and Delft3d is still waiting to be compiled on the local machine.
I already tried different MPICH2 versions (1.3.5, 1.4.1, 3.0.4).

Has anybody a similar problem or a solution to what I am doing wrong here? For the error msg. please see the attached file.
Looking forward to suggestions,

kind Regards,

Oliver

Comands used:
======================
home/lojek/mpich2_1.4.1/configure --prefix=/usr/local/bin/mpi-install_1.4.1 --with-pm=hydra:mpd 2>&1 |& tee c.txt F77=ifort FC=ifort
make 2>&1 |& tee c.txt F77=ifort FC=ifort
sudo make install 2>&1 | tee mi.txt F77=ifort FC=ifort

For compiling Delft3d
======================
./autogen.sh
CFLAGS='-O2 -fPIC -m64' CXXFLAGS='-O2 -fPIC -m64' FFLAGS='-O2 -fPIC -m64' FCFLAGS='-O2 -fPIC -m64' ./configure --prefix=`pwd`
sudo make ds-install
Adri Mourits, modified 7 Years ago.

RE: Delft3d Compilation Error | MPI 1.4.1 (Answer)

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Oliver,

Can you please post the full make logging?

Thanks.

Regards,

Adri