intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Wave running error

YP
Yi Pan, modified 7 Years ago.

Wave running error

Youngling Posts: 7 Join Date: 6/21/13 Recent Posts
Dear all,
I just download the GUI and compiled the code.
The Flow model runs well, but the wave model is abnormal.
After the initialization finished (couple of lines), the program crashed, but no error. The last word is 'Performing wave computation for: ***.swn'.
When I see the files in the folder, a .swn file has been created. Also there is an empty delft3d.log file. The last created file is a BOTNOW file. No error file.
I tried to copy the swan_4072ABCDE_del_w32_i11_omp.exe to old cases set up with only swan.exe(without delft3D), it works!
Really strange..

Is anyone able to advise?

Thanks


Yi
Adri Mourits, modified 7 Years ago.

RE: Wave running error

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Yi,

The problem might be that the name of your mdw file is too long. What is the name of your mdw file? What happens if you rename it into a simple name (only digits and/or letters), not more than 8 charachters long?

Please report back at this forum your findings. WAVE should be able to handle long names.

Thanks.

Regards,

Adri
YP
Yi Pan, modified 7 Years ago.

RE: Wave running error (Answer)

Youngling Posts: 7 Join Date: 6/21/13 Recent Posts
Hi Adri,
Thank you for reply.
I think I might know what thhe problem is.
I installed a older version of GUI as comparison. That works well.
For the new version, the calculation crashes after the works 'Performing wave computation for: siu.swn '
For the old version, the next followong are messy code but I can fing the works are ' copyed 1 file' in Chinese in the log file, 'cause the system of my computer is in Chinese.
So, I think although the GUI can't recogonize Chinese, the old version manage to print the words in messy code; but the new version can't do that so it crashed.
How can I resolve this..?


Regards,

Yi
RC
Ana Carrasco, modified 7 Years ago.

RE: Wave running error

Padawan Posts: 26 Join Date: 7/23/13 Recent Posts
Hi
I am having the same problem. I just download the GUI and compiled the code, and I was running the tutorial examples. The Flow model runs well, but the wave model crashes. I get the same message 'Performing wave computation for: ***.swn', and a .swn file is also created.

Have you already figure how to solve?
Thanks
Adri Mourits, modified 7 Years ago.

RE: Wave running error

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Ana,

I can't reproduce your problem.
Can you:
  • In Delft3D-GUI, select "Information" ->"Version". A window will popup with a lot of version numbers.
  • Select the full contents of the version window and copy it to a textfile (using <Ctrl>-C, <Ctrl>-V)
  • Attach that text file to a post here on the forum


Thanks.

Adri
RC
Ana Carrasco, modified 7 Years ago.

RE: Wave running error

Padawan Posts: 26 Join Date: 7/23/13 Recent Posts
Hi Adri,

Thanks for your reply

Regards,
Ana Carrasco
YP
Yi Pan, modified 7 Years ago.

RE: Wave running error

Youngling Posts: 7 Join Date: 6/21/13 Recent Posts
Hi Carrasco,
At last I gave up. Just use the old version of GUI to deal with the wave...
RC
Ana Rita Carrasco, modified 7 Years ago.

RE: Wave running error

Padawan Posts: 26 Join Date: 7/23/13 Recent Posts
Yi

Which GUI version you used for wave running?

Best Regards
Ana Rita Carrasco
HL
Hualong Luan, modified 7 Years ago.

RE: Wave running error

Youngling Posts: 3 Join Date: 4/11/13 Recent Posts
Hi,
I also have total the same problem. The version of my using GUI is Delft3D 4.01.00.rc.01. Is there any solution except using older version of GUI?