intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

make error in 6.01.00.2640

DS
Dirk Smit, modified 6 Years ago.

make error in 6.01.00.2640

Youngling Posts: 21 Join Date: 6/18/13 Recent Posts
Hi,
i think a new thread is the better sollution...
I switched to 6.01.00.2640 in the meantime und tried to compile it.
But somehow he doesn't like my setup.
I am using the same build.sh as in my successfull compileattempts with 5.01.00.2163. There it compiles without error.
Here i get the already mentioned make error in the delwaq module.
I even tried to use the mpich2 Settings again, but with the same error.
i tried both mvapich2 and mpich2, but with the same result.


# mpich2version
MPICH2 Version:         1.4.1p1
MPICH2 Release date:    Thu Sep  1 13:53:02 CDT 2011
MPICH2 Device:          ch3:nemesis
MPICH2 configure:       --prefix=/opt/mpich2/1.4.1p1/gcc/ CFLAGS=-fPIC CXXFLAGS=-fPIC FFLAGS=-fPIC FCFLAGS=-fPIC
MPICH2 CC:      gcc -fPIC   -O2
MPICH2 CXX:     c++ -fPIC  -O2
MPICH2 F77:     gfortran -fPIC  -O2
MPICH2 FC:      gfortran -fPIC  -O2
Adri Mourits, modified 6 Years ago.

RE: make error in 6.01.00.2640 (Answer)

Yoda Posts: 1224 Join Date: 1/3/11 Recent Posts
Hi Dirk,

Looking at your configure.log, it seems that you are using gfortran version 4.4.6. That is too old. You must upgrade to at least 4.6.2, see prerequisites.

Regards,

Adri
DS
Dirk Smit, modified 6 Years ago.

RE: make error in 6.01.00.2640

Youngling Posts: 21 Join Date: 6/18/13 Recent Posts
Ok. i will have to look into updating my cluster - it is still running RHEL 6.2.
Since the 5.01 Version seems to be working i will stay with it and come back to you when i have switched the machine to another version...