intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

d3d_filsel error

SS
Soroush Safaei, modified 7 Years ago.

d3d_filsel error

Youngling Posts: 21 Join Date: 3/24/13 Recent Posts
hello every one
I have a weird problem!!! I used to run with delft easily but today I have encountered a weird problem!!whenever I start to run it says that d3d_filsel has stopped working!!!
and after that a wefault.exe application error pop into my screen that says the instruction at 0*771546a referenced memory at 0*00000010. the memory could not be read!!!
what is this!!!what should I do??
please someone give me a clew!!!I am working on my thesis!!!it is really important!!
I may reinstall my windows!!!!
Adri Mourits, modified 7 Years ago.

RE: d3d_filsel error (Answer)

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Soroush Safaei,

It seems that your runtime environment is messed up. May be restarting your machine solves it. If you don't want to stop a running calculation: try to find something weird using the Windows TaskManager.

If the problems remain everytime you start Delft3D-GUI, you can try running calculations using simple batch scripts, see the site for more information.

For your information: "d3d_filsel" is a small executable, part of the Delft3D-GUI, that creates a pop-up Window in which you can select a file on your system. It is used on several points in the GUI. "werfault.exe" (with an "r") is a Microsoft tool to report errors. If you think this one causes problems, you can switch it off with instructions from this site.

Regards,

Adri
SS
Soroush Safaei, modified 7 Years ago.

RE: d3d_filsel error

Youngling Posts: 21 Join Date: 3/24/13 Recent Posts
Thanks Adri Mourits for your answer....I've tried these and this was really helpful....
and I have another question...
the first time I worked with delft3D I could see the bathymetry in the visualization area...
but now it just seems that there is no depth data available!!!!
nothing is shown and of course after simulation the results have the depth -999 that is for the places without depth data!!!
what is wrong in this step!!??
I have made the depth data in quicken and it seemed to be fine!!!
Thank for your help again....
U
Arnold van Rooijen, modified 7 Years ago.

RE: d3d_filsel error

This question is answered in this thread