intro story D-Flow FM


D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 


We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.





Sub groups
D-Flow Flexible Mesh
Cohesive sediments & muddy systems


Message Boards

Unable to compile

Huy Tran Quang Pham, modified 8 Months ago.

Unable to compile

Youngling Posts: 3 Join Date: 3/27/19 Recent Posts
Hello everyone,
Yesterday I just downloaded the D3DFM source code
(the latest, with highest number). Then I followed the instructions in
src/README to compile it. When it came to CFLAGS='-O2' CXXFLAGS='-O2'
FFLAGS='-O2' FCFLAGS='-O2' ./configure --prefix=`pwd` --with-netcdf
--with-mpi --with-metis --with-petsc, it failed, the final lines are:
gfortran: error: unrecognized command-line option '-showme:link'
gfortran: fatal error: no input files
compilation terminated.
configure: creating ./ creating libtool
checking for the extension of Delft3D plugins... .so
./configure: line 20190: ACX_MKL: command not found
checking if PETSc is wanted... yes
checking for PETSc... no
checking for PETSc... no
configure: error: Package requirements (PETSc >= 3.8) were not met:

Package 'PETSc', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PETSc_CFLAGS
and PETSc_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
the way I'm using gcc & gfortran 10 (I know D3D ask me to use gcc
<8 but I tried many ways to downgrade, just can't, and I can't change
the OS, much more trouble), may be the "gfortran: error:" is because of
this? Other things are, I installed every prerequisites except that
gfortran version I can't go lower. But the terminal showed that the
program was unable to find mpi & petsc. For petsc you can see
clearly from above, for mpi it was a whole dozens of lines, I put them
in the attachment "err.txt". There were something unusual because I compiled OpenFOAM succesfully (a software that require mpi too).
I tried again and again these two days,
and now I'm hopeless. Did search on forum, there were some questions
quite similar as mine but I can't use those solution. I really need
Delft3D, it is as a treasure to me but, I can't change the OS, how can I
compile successfully emoticon help me please.
Forgot to say, I'm using Fedora 32.