intro story D-Flow FM


D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 


We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.





Sub groups
D-Flow Flexible Mesh
Cohesive sediments & muddy systems


Message Boards

Problem compiling mipch2 with gfortran

Benoit Seille, modified 6 Years ago.

Problem compiling mipch2 with gfortran

Youngling Posts: 4 Join Date: 1/6/14 Recent Posts
Facing many troubles trying to compile with intel12, I decided to try with gnu.

Using tag 3185 on linux (centos 6.5)
I have installed
GMP 5.1.3
MPFR 3.1.2
MPC 1.0.2
GCC 4.6.2
autoconf 2.68
automake 1.11.1

I have tried with both mpich2 1.0.8 and 1.4.1.
I follow a configure command, I found here and that has worked.
./configure --prefix=.../mpich/mpich2-1.4.1_gnu/install --with-pm=mpd --enable-shared --enable-sharedlibs=gcc F77=gfortran FC=gfortran CC=gcc CXX=g++ FCFLAGS=-fPIC CFLAGS=-fPIC CCFLAGS=-fPIC CXXFLAGS=-fPIC

(...=good folders).
The error message I get is:

checking if real*8 is supported in Fortran 90... yes
configure: error: Unable to determine Fortran 90 integer kinds for MPI types. If you do not need Fortran 90, add --disable-fc to the configure options.

Any idea of what I am doing wrong? I suppose my installation of gcc is not good.
Any exemples of configuring gcc might be helpfull
I am only doing this
.../gcc/V4.6.2/src/gcc-4.6.2/configure --prefix=.../gcc/V4.6.2/tools/ --with-gmp=.../gmp-5.1.3/install --with-mpfr=.../mpfr-3.1.2/install --with-mpc=.../mpc-1.0.2/install
make install

Thank you for your help
Adri Mourits, modified 6 Years ago.

RE: Problem compiling mipch2 with gfortran

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Benoit,

Our gcc-4.6.2 is compiled with:
export PATH=/opt/autoconf-2.68/bin:/opt/automake-1.11.1/bin:${PATH}
../gcc-4.6.2/configure --prefix=/opt/gcc-4.6.2 --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --disable-gnu-unique-object --enable-languages=c,c++,fortran --disable-libgcj --with-tune=generic --with-arch_32=i586

Compiling the Delft3D source code does not need a lot of flags. See the example in the README file.
--prefix must be `pwd` for make ds-install to work properly and the examples to run without changing scripts or copying binaries.
Example logs of autogen/configure/make are in subdirectory src/logs. Your configure line causing troubles is not in there. So I agree with you that something seems to be wrong with the gcc compilation.

Hope this helps (a bit).