intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Compiling issues again

EA
Ed Atkin, modified 6 Years ago.

Compiling issues again

Padawan Posts: 27 Join Date: 3/27/12 Recent Posts
Hello all,

I have decided to compile a newer tag:
tags/3185

I posted some time ago with the problems I had with compiling last time - things were resolved:
http://oss.deltares.nl/web/delft3d/general/-/message_boards/view_message/183178

Hopefully I can find some assisstence again:

Info:
- windows 7 64bit
- VS2010 Pro
- Intel Fortran Composer XE 2013

(just did a full reinstall/install of VS and Intel Fortran as well - made all windows updates including SP1 for VS)

Using the d_hydro_open_source_vs2010_intel13 solution

Ran a release for win32
Some 66 errors, all of which are:
error C1083: Cannot open include file: 'mpi.h': No such file or directory
Output file attached

Also ran a x64 - no errors. output also attached.
Not much good though as 64bit exe's are not meant to work.

Can anyone help?


edit:

Just tried with tag 3426 as well. Same issue
EA
Ed Atkin, modified 6 Years ago.

RE: Compiling issues again

Padawan Posts: 27 Join Date: 3/27/12 Recent Posts
Update:

Tried compiling a release of tag 5.01.00.2163 in 32 bit

========== Build: 87 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

No Errors!!

474 warnings though, see attached.

All examples ran clean - except i didnt run 05_mormerge as i wasnt sure on whic version of TCL to download.

So possible issue with newer tag versions
Qinghua Ye, modified 6 Years ago.

RE: Compiling issues again (Answer)

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Hi, Ed,

Thanks for the information!

Rev. 3495 should work!

Qinghua
EA
Ed Atkin, modified 6 Years ago.

RE: Compiling issues again

Padawan Posts: 27 Join Date: 3/27/12 Recent Posts
HI Qinghua,

Compile went well. See attached output.

========== Build: 86 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

I thought we were supposed to used tagged versions?!?

Anyway, examples went well

Have copied myCode/bin/win32 to myDelft3d/win32.
I tried running the 01_Standard example through the GUI (4.01.00.rc.07) to ensure that the GUI was working and I got the attached error

Cheers,

Ed
Qinghua Ye, modified 6 Years ago.

RE: Compiling issues again

Jedi Council Member Posts: 612 Join Date: 3/2/11 Recent Posts
Dear Ed,

Indeed the tagged version is supposed to be used. But this time, we missed the small bug before tagging it and it will be solved in the next tagged version. Yes, we should use the tagged versions.

The error you showed complains that the create_config_xml.tcl is not found.

After correct compiling, It should be in /bin/win32/menu/bin. If not, you can also copy the file manually. See what will happen. It should not be necessary. But I don't know why you encounter this problem.

Regards,

Qinghua
EA
Ed Atkin, modified 6 Years ago.

RE: Compiling issues again (Answer)

Padawan Posts: 27 Join Date: 3/27/12 Recent Posts
Hi Qinghua,

Yeah I hadn't merged the files from myCode/bin/win32 with myDelft\win32 contents. (I had just copied the myCode/bin/win32 folder in to myDelft\win32 ).
'Thanks for your help.

Ed