intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

GUI installation not working

TS
Thomas SAILLOUR, modified 6 Years ago.

GUI installation not working

Youngling Posts: 24 Join Date: 4/6/14 Recent Posts
Hello,

I am new in this community, and I think arrived at the very last step of GUI installation.

Info:
I am running an Ubuntu 12.04 LTS 64bit

The compiling worked without problems.
I just have a problem when I am trying to run the file in etc/profile.d/delft3d.sh

when I enter the following in the command I have :

~/Documents/delft3d/myprog$ . etc/profile.d/delft3d.sh
No Delft3D home directory found.
Please contact Deltares (delft3d.support@deltares.nl)

and:

~/Documents/delft3d/myprog$ . /etc/profile.d/delft3d.sh
bash: /etc/profile.d/delft3d.sh: No such file or directory


I don't which PATH to to specify in the delft3d.sh script which is located in :
usr/Documents/delft3d/myprog/etc/profile.d/delft3d.sh

the script is in my case :

#-----------------------------------------------------------------------
D3D_HOME=/opt/delft3d
#-----------------------------------------------------------------------

and I have created a directory with the same name located in:
~/Documents/delft3d/myprog/opt/delft3d/intel/D3D_HOME$

What should I do to obtain the interface?

Thank you

Thomas
TS
Thomas SAILLOUR, modified 6 Years ago.

RE: GUI installation not working (Answer)

Youngling Posts: 24 Join Date: 4/6/14 Recent Posts
Ok I solved it!

Just a little problem in the PATH : in my case I just replaced "/opt/delft3d" by "opt/delft3d" in delft3d.sh file and it worked