intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

coupled flow-wave model stalls during initialisation

AO
Andy ONeill, modified 6 Years ago.

coupled flow-wave model stalls during initialisation

Youngling Posts: 4 Join Date: 2/13/13 Recent Posts
Hi,

I'm trying to troubleshoot what's causing my model to stall. It's a hires FLOW-WAVE simulation, and I've run it before with different initial conditions, but upon setting this one up and trying to run it, it stalls during the initialisation process:
Part VII - Initialisation output...

It writes the FLOW2WAVE_DATA file, and then stops doing anything. No errors are given. I've gone through all the input data and can't find anything. Any primary suspects I should be looking at?
I greatly appreciate any suggestions, as this is time-sensitive.

Many thanks.
Adri Mourits, modified 6 Years ago.

RE: coupled flow-wave model stalls during initialisation

Yoda Posts: 1224 Join Date: 1/3/11 Recent Posts
Hi Andy,

Double check that online visualisation is switched off, see this FAQ.

Double check that file dioconfig.ini is present in the working directory.

Be sure to start a calculation with a working directory as clean as possible, see this FAQ.

Do you see both FLOW and WAVE being started? Your description points to WAVE not being started (correctly). Does the WAVE screen output contain error messages? Does the tri-diag file contain error messages?

Can you still run the "...\examples\03_flow-wave" testcase in the source code in the same way as you try to start your calculation?

Regards,

Adri