intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

undefined symbol: MPI_Init

XW
XIN WEN, modified 4 Years ago.

undefined symbol: MPI_Init

Youngling Posts: 2 Join Date: 1/12/16 Recent Posts
Dear all,

I am compiling Delft3D (version 5656) on my Ubuntu (14.04.3) virtual box. I have install the per-requested tools. Then I install using step 1 in Readme file

Compiling on Linux
==================
1) In directory "src", do one of the following two options:
Option A):
./autogen.sh
CFLAGS='-O2' CXXFLAGS='-O2' FFLAGS='-O2' FCFLAGS='-O2' ./configure --prefix=`pwd`
make ds-install

No error occurs, after install the terminal shows

----------------------------------------------------------------------
Libraries have been installed in:
/home/wen/delft3d_repository/src/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,-rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
.
.
.

cp: missing destination file operand after ‘/home/wen/delft3d_repository/src/../bin/lnx64/flow2d3d/bin’
Try 'cp --help' for more information.
installing nesthd1 . . .
Gathering libraries for nesthd1...
installing nesthd2 . . .
Gathering libraries for nesthd2...

===================================

However, when I run the test case: /run_flow2d3d.sh , error shows as
../../bin/lnx64/flow2d3d/bin/d_hydro.exe: symbol lookup error: ../../bin/lnx64/flow2d3d/bin/libflow2d3d.so: undefined symbol: MPI_Init

the config and make log is attached.

Thanks in advanced,

Wen Xin
XW
XIN WEN, modified 4 Years ago.

RE: undefined symbol: MPI_Init (Answer)

Youngling Posts: 2 Join Date: 1/12/16 Recent Posts
Finally, I solved the problem and am successful in running the testcase in 01_standard in my ubuntu 14.04.3. In case some one are interesting in the process, I will list it below

1, Manually Installed MPICH (3.1.2), NETCDF-c(4.3.2), and NET-CDF-Fortran(4.4.2)
Note that there seems is a bug when i use latest version NETCDF(4.4.0)

2. I used option B (build.sh) in readme file to solve the problem, by setting the route of NETCDF-c(3.3.2), NET and MPICH (3.1.2), as a exmaple
# mpich
if [ "$compiler" = 'gnu' ]; then
addpath PATH /usr/bin
export MPI_INCLUDE=/usr/include
export MPILIBS_ADDITIONAL="-L/usr/lib -lfmpich -lmpich -lmpl"
# export MPILIBS_ADDITIONAL=" "
export MPIFC=/usr/bin/mpif90

Note that: NETCDF and MPICH are install under /usr

2. there is not need to set the PATH and LD_LIBRARY_PATH in my case.

The build.h is attached for the one who might be interested.
Adri Mourits, modified 4 Years ago.

RE: undefined symbol: MPI_Init

Yoda Posts: 1224 Join Date: 1/3/11 Recent Posts
Hi Xin Wen,

Thank you for posting your solution.

Regards,

Adri