intro story D-Flow FM

 

D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
 
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 

 

=======================================================
We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 
/web/delft3dfm/forum

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.

=======================================================

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems

 


Message Boards

Error running examples

Francesco Enrile, modified 5 Years ago.

Error running examples

Padawan Posts: 26 Join Date: 3/25/12 Recent Posts
Hi all,

I compiled Delft3D tag 5740 on Ubuntu 14.04 LTS using gfortran.
Everything seem OK but when I run the examples I always get the following error:

At line 831 of file prterr.f90 (unit = 33, file = 'tri-diag.f34')
Fortran runtime error: Sequential READ or WRITE not allowed after EOF marker, possibly use REWIND or BACKSPACE


However, this errors seems not to affect the result of the simulations.


Besides, when I run specifically example 10 I get:

At line 136 of file rdpart.f90 (unit = 902, file = '')
Fortran runtime error: File already opened in another unit

Delwaq2 did not run correctly.


Thank you very much for any help.
Best regards,
Francesco
U
Alejandra Ortiz, modified 4 Years ago.

RE: Error running examples

I am running into the exact same error when trying example 10. Does anyone have a good idea of how to fix this? I cannot run example 10 successfully (and am having issues with another Del-waq test case I've been trying).

Thank you,

Alejandra Ortiz
PR
perez roberts, modified 10 Months ago.

RE: Error running examples

Youngling Posts: 1 Join Date: 7/21/20 Recent Posts
Hello, I encountered the same problem. I am using Ubuntu 18.10 and got the error "Delwaq2 did not run correctly" in the installation process.I did some research to fix this problem and got rid of this problem thanks to this website. Or you can take the necessary actions in the article here.
JJ
Jason Josh, modified 2 Months ago.

RE: Error running examples

Youngling Posts: 1 Join Date: 3/8/21 Recent Posts
Is file "aclocal.m4" generated? If it is: does it give you more information? Can you post it here? If it isn't: Do you have write permission in this directory? Is there enough free space (1Mb should do)?

Is there any file with extension ".log" present, in the src root directory or subdirectory "log"? Can you post it here?
 
iMessageapp