intro story D-Flow FM


D-Flow Flexible Mesh

D-Flow Flexible Mesh (D-Flow FM) is the new software engine for hydrodynamical simulations on unstructured grids in 1D-2D-3D. Together with the familiar curvilinear meshes from Delft3D 4, the unstructured grid can consist of triangles, pentagons (etc.) and 1D channel networks, all in one single mesh. It combines proven technology from the hydrodynamic engines of Delft3D 4 and SOBEK 2 and adds flexible administration, resulting in:

  • Easier 1D-2D-3D model coupling, intuitive setup of boundary conditions and meteorological forcings (amongst others).
  • More flexible 2D gridding in delta regions, river junctions, harbours, intertidal flats and more.
  • High performance by smart use of multicore architectures, and grid computing clusters.
An overview of the current developments can be found here.
The D-Flow FM - team would be delighted if you would participate in discussions on the generation of meshes, the specification of boundary conditions, the running of computations, and all kinds of other relevant topics. Feel free to share your smart questions and/or brilliant solutions! 


We have launched a new website (still under construction so expect continuous improvements) and a new forum dedicated to Delft3D Flexible Mesh.

Please follow this link to the new forum: 

Post your questions, issues, suggestions, difficulties related to our Delft3D Flexible Mesh Suite on the new forum.





Sub groups
D-Flow Flexible Mesh
Cohesive sediments & muddy systems


Message Boards

Compiling on Ubuntu 11.10 64 bits

Eric Nardi, modified 9 Years ago.

Compiling on Ubuntu 11.10 64 bits

Youngling Posts: 2 Join Date: 5/12/11 Recent Posts
Hello everyone,

I'm trying to compile the trunk version of the code on Ubuntu 11.10 64 bits. I have ifort 11.0.084 and mpich2 compiled with ifort installed in /opt/mpich2.
Everything goes fine, until the moment it starts to compile DATSEL, KUBINT and LINT, inside the tools_gpl directory. Everything else compiles. I went into all the other directories and ran "make", it worked. But these 3 seems to have some kind of problem that I can't figure out.

The error is as follows:

/bin/bash ../../../../../libtool --tag=CXX   --mode=link g++ -std=c++98 -D_GNU_SOURCE -DSTR_LEN_AT_END -pthread -O2 -fPIC -m64    -o datsel main.o ../../../../../tools_gpl/datsel/packages/datsel_f/src/libdatsel_f.a ../../../../../tools_gpl/datsel/packages/datsel_version_number/src/libdatsel_version_number.a ../../../../../utils_lgpl/nefis/packages/nefis/src/libnefis.a ../../../../../utils_lgpl/nefis/packages/nefis_version_number/src/libnefis_version_number.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow/src/libutils_flow.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow_c/src/libutils_flow_c.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow_version_number/src/libutils_flow_version_number.a -ldl -L/opt/intel/composer_xe_2011_sp1.7.256/compiler/lib/intel64 -L/opt/intel/composer_xe_2011_sp1.7.256/mkl/lib/intel64 -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1 -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib -L/lib/x86_64-linux-gnu -L/lib/../lib64 -L/lib/../lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../.. -L/lib64 -L/lib -L/usr/lib -lifport -lifcore -limf -lsvml -lm -lipgo -lirc -lpthread -lirc_s -ldl -lirc -lsvml -lmcheck -lifcore -limf -lexpat -lstdc++
libtool: link: g++ -std=c++98 -D_GNU_SOURCE -DSTR_LEN_AT_END -pthread -O2 -fPIC -m64 -o datsel main.o  ../../../../../tools_gpl/datsel/packages/datsel_f/src/libdatsel_f.a ../../../../../tools_gpl/datsel/packages/datsel_version_number/src/libdatsel_version_number.a ../../../../../utils_lgpl/nefis/packages/nefis/src/libnefis.a ../../../../../utils_lgpl/nefis/packages/nefis_version_number/src/libnefis_version_number.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow/src/libutils_flow.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow_c/src/libutils_flow_c.a ../../../../../utils_lgpl/utils_flow/packages/utils_flow_version_number/src/libutils_flow_version_number.a -L/opt/intel/composer_xe_2011_sp1.7.256/compiler/lib/intel64 -L/opt/intel/composer_xe_2011_sp1.7.256/mkl/lib/intel64 -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1 -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib -L/lib/x86_64-linux-gnu -L/lib/../lib64 -L/lib/../lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../.. -L/lib64 -L/lib -L/usr/lib -lifport -lm -lipgo -lpthread -lirc_s -ldl -lirc -lsvml -lmcheck -lifcore -limf /usr/lib/x86_64-linux-gnu/ -lstdc++ -pthread
/opt/intel/composer_xe_2011_sp1.7.256/compiler/lib/intel64/ undefined reference to `dlsym'
collect2: ld returned 1 exit status

I google and tried a lot of things, but nothing resolved this issue.

I succesfully compiled it with gfortran and ran the examples, but with ifort I'm having no luck. I also tried the newest version of ifort and got the same error.

Anybody have an idea of what's going on?!


Adri Mourits, modified 9 Years ago.

RE: Compiling on Ubuntu 11.10 64 bits

Yoda Posts: 1221 Join Date: 1/3/11 Recent Posts
Hi Eric,

Try adding the link flag -ldl