Migration status

  • Home Page: Activity map.

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Back

compiling delft3d on linux /usr/bin/ld: cannot find -lnetcdff

xia wei, modified 2 Years ago.

compiling delft3d on linux /usr/bin/ld: cannot find -lnetcdff

Youngling Posts: 16 Join Date: 10/24/16 Recent Posts
Hello,

I am trying to compile the Delft3d open source on linux, because I want to use the run the delft3d model on the super computer further. The linux distribution I use is Ubuntu 16.01, and the Delft3d open source is latest tags version 6686. I have no problem with the ./configure and also make, but when I install I have got the error /usr/bin/ld: cannot find -lnetcdff . I install the netcdf with additional open source I download from the office website, with the version 4.1.3 and install into the direction /opt/netcdf. so I set the environment path like:

NETCDF_FORTRAN_LIBS=/opt/netcdf/lib
NETCDF_LIBS=/opt/netcdf/lib
NETCDF_FORTRAN_CFLAGS=/opt/netcdf/include
NETCDF_CFLAGS=/opt/netcdf/include
NETCDF_INCDIR=/opt/netcdf/include
LD_LIBRARY_PATH=/opt/netcdf/lib
NETCDF_LIBDIR=/opt/netcdf/lib


but I still get the error:

/usr/bin/ld: cannot find -lnetcdff
collect2: error: ld returned 1 exit status
Makefile:686: recipe for target 'libflow2d3d.la' failed
make[7]: *** [libflow2d3d.la] Error 1
make[7]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d/packages/flow2d3d/src'
Makefile:732: recipe for target 'install-recursive' failed
make[6]: *** [install-recursive] Error 1
make[6]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d/packages/flow2d3d/src'
Makefile:889: recipe for target 'install' failed
make[5]: *** [install] Error 2
make[5]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d/packages/flow2d3d/src'
Makefile:489: recipe for target 'install-recursive' failed
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d/packages/flow2d3d'
Makefile:499: recipe for target 'install-recursive' failed
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d/packages'
Makefile:489: recipe for target 'install-recursive' failed
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl/flow2d3d'
Makefile:494: recipe for target 'install-recursive' failed
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory '/home/xiawei/delft3d_6686/src/engines_gpl'
Makefile:549: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1

so is this because I should not install this under the /opt floder?
compiling delft3d error