intro story DELWAQ


DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.




Sub groups
D-Flow Flexible Mesh

Cohesive sediments & muddy systems


Message Boards

point source waq

Karoline Wischnewski, modified 4 Years ago.

point source waq

Youngling Posts: 5 Join Date: 12/1/16 Recent Posts
hello everybody

I am trying to set up a WAQ computation with one decayable tracer. I want to have this tracer as a point source with time varying concentration. So I am in the discharges tab, where there are already the discharges listed from my hydrdynamics computations. Here I would like to add another source via the Import button but I seem not to be able to put together the timeseries file correctly.

I attached the .tim file I tried it with. The file gets accepted and also lists the correct times and all but when I go back into the data via the Edit-button all values show up as zero. i tried manipulationg the .inp-file but to no success either. everything I change there just gets ignored. I also tried importing it as a boundary timesieries (even though I don't want it as such) but it also just lists a bunch of zeros.

I would be very happy if someone has some insight in how to solve this.

Thank you Karoline
Michel Jeuken, modified 3 Years ago.

RE: point source waq (Answer)

Jedi Knight Posts: 154 Join Date: 1/21/13 Recent Posts
Sorry for the late reply. The answer is in the extra spaces in the substance name.

parameter 'dTR1 ' unit '[ug/m3]'

is not accepted, but this is:

parameter 'dTR1' unit '[ug/m3]'

It might have been nicer if the user interface neglected the extra spaces.