Home_intro

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

about waq (1) execution error...

U
Anonymous, modified 3 Years ago.

about waq (1) execution error...

Posts: 1
Hi, I am Seokil Jeong.
I'm a student, a beginner in delft3d, and studying waq-tutorials.
There were two major problems in this process.
First, the following problems occurred in PLCT. The path is not related to my computer, and I wonder how to reset the path.
Second, the first problem was solved by using a file already created in the tutorial, but another problem occurred in the execution of waq (1).

Please give detailed and easy explanation.

Thank you very much.
Best regard.
AM
Arjen Markus, modified 3 Years ago.

RE: about waq (1) execution error...

Jedi Knight Posts: 223 Join Date: 1/26/11 Recent Posts
The first problem you describe has to do with the unexpected path - c:\users\kko\desktop\delft3d\... Did you install Delft3D in your desktop directory? I suggest you use the default path offered by the installer. Perhaps another disk, like d: or f:. I have never tried this type of installation directory myself, but it strikes me as one possible cause for the problem. The second problem shows that Delft3D was installed in F: - so there is a discrepancy here, which may well be caused by the somewhat special character of the "desktop" directory.

The second problem is another puzzle. Some file is being read and seems to be too short but the last part of the name is missing, so we do not know which file it is. What does the report on the input say (the .lst file)? What does the input file look like exactly? Even though this is coming from the tutorial, it would help if we can see the exact files as you have them.
MJ
Michelle Jeuken, modified 3 Years ago.

RE: about waq (1) execution error...

Jedi Knight Posts: 154 Join Date: 1/21/13 Recent Posts
Hi Seokil Jeong,

Both problems are related to the fact the the location of the bloom.spe-file is not set correclty. This might be due to the fact that the installation is not on the location where it was installed originally any more. It might help to run the bat-file 'substitute_delft3d_env' from the location where the installation is now. You might also want to look at the Windows environmental variables, where there should be a varaible named D3D_HOME, that should contain the path to your D3D installation...

Michelle