Migration status

  • Home Page: Activity map.

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

Delft3D-SWAN error - Segementation Fault (core dumped)

NV
Nate VanArendonk, modified 1 Year ago.

Delft3D-SWAN error - Segementation Fault (core dumped)

Youngling Posts: 3 Join Date: 2/10/17 Recent Posts
Hi All,

I am having trouble running some of my domains when I increase the resolution of the grid. I am having success when I run my model on my 62.5 meter grid which is a 1157x871 grid. Then when I cut the resolution in half to 32.25 meters with a grid of 2313x1741, I am met with an error while Swan is trying to write output files. Here is what I get:

+SWAN is processing output request 1
Segmentation fault (core dumped)
*** WARNING: unable to run SWAN using "swan.sh". Trying with "swan.bat" ...
sh: 1: swan.bat: not found
>>...End of SWAN run
*** ERROR: file 'norm_end' expected to signal a correct SWAN calculation

Unfortunately a print file or error file are not created so this is my only clue as to what the error is. I've never encountered a Segmentation Fault (core dumped) error before. A quick internet search revealed that it means Swan is trying to access memory it has not been told it has access too. I am wondering if anyone has encountered an error like this in the past? In an attempt at a quick fix, I upped the available memory to 53 gigs and this did not solve the problem ( the model only uses around 22) I should note that I am running Delft3D-64bit Swan on Linux - Ubuntu through a virtual machine.

I am a little curious why the coarser resolution grid works then when I cut the resolution in half and increase the grid size, it throws this error, with plenty of available memory. If anyone has any suggestions on how I can fix this problem it would be greatly appreciated! Realistically, I do not need to run my models at a resolution of 32.25m however, I have a very large domain at 100 meter resolution which encompasses these smaller domains (grid size is 2438x3541). When I run this model it uses around 48 gigs of RAM and after SWAN is done running and attempting to write the outputs I am met with the same error that I pasted above.

***Summary: I have large domains that I am running on 64-bit Swan on linux. The models run and when swan is attempting to process and write the output files, I am met with an error of "Segmentation Fault (core dumped). Any advice on how to fix this?


Thanks!
Nate
Oliver Lojek, modified 1 Year ago.

RE: Delft3D-SWAN error - Segementation Fault (core dumped)

Jedi Knight Posts: 111 Join Date: 4/30/13 Recent Posts

Dear Nate,

I am facing the same issue with my mesh, as soon as I start increasing the resolution (<50 m) on a coupled flow-wave simulation, SWAN gives me the same error (also running on 64bit Linux in MPI-parallel with plenty of resources). 

Did you find a solution to the problem? I am a little bit puzzled atm.

Cheers,

Oliver

Oliver Lojek, modified 1 Year ago.

RE: Delft3D-SWAN error - Segementation Fault (core dumped)

Jedi Knight Posts: 111 Join Date: 4/30/13 Recent Posts

Short update on that note; a further increase in resolution (<20 m) renders the model operational again. However, different resolutions on the different grids FLOW (20x20m) and WAVE (60x60m) seem not to work on the version I am running, hence I have to run both grids at the same resolution, which is a bit resouce inefficient,