Migration status

  • Home Page: Activity map.

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

Compilation - VS won't copy wave.exe

LD
Lucas De Oliveira Toledo Morais, modified 6 Months ago.

Compilation - VS won't copy wave.exe

Youngling Posts: 2 Join Date: 7/27/17 Recent Posts

Hello  everyone,

 

I am currently trying to compile Delft3D (tag: Delft3D_FM_62926)

 

i was able to do it for every solution, apart from the wave one.

 

I keep getting the error "wave_exe : error PRJ0019: A tool returned an error code".

 

Apparently the compiler doesn't know wether  "...\bin\x64\dwaves\bin\wave.exe"  is a folder or a file and can't copy the wave.exe to the directory.

---------

Log message:

"Ist das Ziel C:\Delft3D\Repository\Delft3D_FM_62926\src\bin\x64\dwaves\bin\wave.exe ein Dateiname
oder ein Verzeichnisname"

--------

 

I followed the instructions on this thread "https://oss.deltares.nl/web/delft3d/general1/-/message_boards/message/336176".

I deleted the destination folder, changed the Delft3D folder to C:\Delft, tried to manually copy the wave.exe to the destination folder.

 

None of the above solved my problem.

The complete log follows attached.

 

Any light on this?

 

Best regards,

 

Lucas