Home_intro

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

Compilation Error of Delft3D in Centos 7 with Intel 19

SD
Sathish D, modified 3 Months ago.

Compilation Error of Delft3D in Centos 7 with Intel 19

Youngling Posts: 1 Join Date: 11/29/12 Recent Posts
I had tried hardly by every possible means to compile the source by myself in Centos 7 with the intel 19 FORTRAN compiler but was unsuccessful. I could compile the code but when during make ds-install I end with the following error
concat.f(40): catastrophic error: **Internal compiler error: internal abort** Please report this error along with the circumstances in which it occurred in a Software Problem Report.  Note: File and line given may not be explicit cause of this error.
compilation aborted for concat.f (code 1)
make[6]: *** [concat.lo] Error 1

I tried almost with all the recent version starting from 8163 to 9180 but somehow finally I am ending up with the above error. I am attaching the log file of make with this query for reference. I could get the flow model running with this but not wave which for me is important.
I had previously compiled the code in Ubuntu 18 with gfortran and was using for my research purposes. I wish to go with intel but could not make it successfully. Hoping to find some solution here.

Thank you

Attachments: