Home_intro

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

Make fails! Compiling on Linux Ubuntu 18.04.5 LTS

JN
Josias NONGBE, modified 1 Month ago.

Make fails! Compiling on Linux Ubuntu 18.04.5 LTS

Youngling Posts: 2 Join Date: 1/24/20 Recent Posts
Hi, I tried to compile delft3d for the first time on Linux following instructions  of this website 
 https://www.nowacki.org/delft3d_ubuntu_linux_notes.html based on the instrutions of https://oss.deltares.nl/web/delft3d/source-code , but I got a problem at the final (I think ) step of the compilation/compiling , " 20210120.052122 :: Make fails! " , I tried the solution of the first website listed above... And the Make Fails! Is persistent. What can I do? 
Here a copy of my command lines (terminal) 20210120.052119 :: Running make ds-install &> logs/make.log
20210120.052122 :: Make fails!
ben@ben-Latitude-E5540:~$ export MPI_INCLUDE=/usr/include/mpich2
ben@ben-Latitude-E5540:~$ export MPILIBS_ADDITIONAL="-L/usr/lib/mpich2 -lfmpich -lmpich -lmpl"
ben@ben-Latitude-E5540:~$ export MPIFC=/usr/bin/mpif90
ben@ben-Latitude-E5540:~$ 2367/src/build.sh -gnu -64bit
Using GNU compilers in /usr/bin
Current settings:
export ACLOCAL=""
export AUTOMAKE=""
export AUTOHEADER=""
export AUTOCONF=""
export AUTORECONF_FLAGS=""
export LIBTOOLIZE=""
export LDFLAGS=""
export LDFLAGSMT_ADDITIONAL=" "
export LD_LIBRARY_PATH=""
export MPIFC="/opt/mpich2-1.4.1-gcc-4.6.2/bin/mpif90"
export MPI_INCLUDE="/opt/mpich2-1.4.1-gcc-4.6.2/include"
export MPILIBS_ADDITIONAL="-L/opt/mpich2-1.4.1-gcc-4.6.2/lib -lfmpich -lmpich -lmpl"
export PKG_CONFIG_PATH=""
export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin"
20210120.053034 :: Running ./autogen.sh --verbose &> logs/autogen.log
20210120.053050 :: Running CFLAGS='-O2 ' CXXFLAGS='-O2 ' FFLAGS='-O2 ' FCFLAGS='-O2 ' ./configure --
prefix=/home/ben/2367/src &> logs/configure.log
20210120.053111 :: Running make ds-install &> logs/make.log
20210120.053115 :: Make fails!