Migration status

  • Home Page: Activity map.

intro story DELWAQ

DELWAQ

DELWAQ is the engine of the D-Water Quality and D-Ecology programmes of the Delft3D suite. It is based on a rich library from which relevant substances and processes can be selected to quickly put water and sediment quality models together.

The processes library covers many aspects of water quality and ecology, from basic tracers, dissolved oxygen, nutrients, organic matter, inorganic suspended matter, heavy metals, bacteria and organic micro-pollutants, to complex algae and macrophyte dynamics. High performance solvers enable the simulation of long periods, often required to capture the full cycles of the processes being modelled.

The finite volume approach underlying DELWAQ allows it to be coupled to both the structured grid hydrodynamics of the current Delft3D-FLOW engine and the upcoming D-Flow Flexible Mesh engine (1D-2D-3D) of the Delft3D Flexible Mesh Suite (or even other models such as TELEMAC).

'DELWAQ in open source' is our invitation to all leading experts to collaborate in further development and research in the field of water quality, ecology and morphology using Delft3D. Feel free to post your DELWAQ related questions or comments in this dedicated forum space. If you are new to DELWAQ, the tutorial (in the user manual) is a good place to start. A list of DELWAQ related publications is available here.

** PLEASE TAG YOUR POST! **

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ

Cohesive sediments & muddy systems

 


Message Boards

Coupling point error

HB
Hadiseh Bolkhari, modified 3 Years ago.

Coupling point error

Youngling Posts: 4 Join Date: 1/8/16 Recent Posts
Hello all,

I'm trying to run wave coupling with flow and getting the following error.

1) Error during initialization of subdomains: check tri-diag files.
OR
2) "thirdgrid": Wrong coupling point at (835, 1) Kcs=0 KcsInside=0

To narrow down the problem I even tried to remove the part of the grid that makes the error but when I run it gives the same error for another coupling point.

From reading this forum I have made sure to do these things:
1) I use RGFGRID to make my ddb file, not manually with text edtors
2) I make sure to delete all com and trih files after each run
3) I do not have any dry points

Thanks,
Hadiseh