null

Message Boards

Problem with coupling a ddb file

fateme Mahyari, modified 2 Years ago.

Problem with coupling a ddb file

Youngling Posts: 4 Join Date: 11/2/16 Recent Posts
Hi

I have a problem with coupling a ddb file. when I open ddb file stop time and time step are different from the related files. stop time is shorter and step time is 4 hrs however in 3 related hyd file they are 2s. Anyway I coupled that ddb file but when I opened that file in the Define input-Hydrodynamics it says there is a problem with discharge. what should I do? do you have any idea what is the problem?

Best Regards,
Fateme
Michel Jeuken, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 156 Join Date: 1/21/13 Recent Posts
Hi Fateme,

Your description is quite general. Is this a 'classic' dd calculation with separate grids? Then it might be that the WAQ output period and intervals might be set differently across the domains. These settings must be the same for all domains. With 'parrallel' dd running (only one grid) it should be the same for all grids automatically

greetings,
Michel
fateme Mahyari, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 4 Join Date: 11/2/16 Recent Posts
Hi Dear Michel
Thanks for your respond. My model has 3 grid parts. All of three parts have the same time step, start and stop. but in ddb file stop and step time changes. as you can see in the attached file. Ignoring all of those issues I tried to couple hyd file which I saved with that ddb file but it ended with error which I attached it as well. The output in flow module works very good, but I do not know what is the problem. do you have any Idea what should be wrong?
Thanks
Regards,
Fateme
Michel Jeuken, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 156 Join Date: 1/21/13 Recent Posts
Hi Fateme,

Hm, that looks a bit strange. The ddb file does not contain any information on the time step, so it shouldn't come from there. Could you post your ddb-file and hyd-file?

I also must say that the communication time step of 2 seconds is quite small for water quality.

regards,
Michel
fateme Mahyari, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 4 Join Date: 11/2/16 Recent Posts
Hi Michel

Thanks for your reply. I attached my ddb and hyd file. what is your suggestion about time step?
Michel Jeuken, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 156 Join Date: 1/21/13 Recent Posts
Another issue I could think of is that you might be using WAVE? This will affect the com-*.dat files in such a way that coupling with WAQ is not possible any more. To solve this, you should switch on Export WAQ Input to produce direct input for Delwaq (see screenshot below). You should then run ddcouple using the ddb-file as it is produced by FLOW. You don't need to create a hyd file with the coupling user interface.

And the best time step for communication with WAQ depends on the study area. On the one hand, the time step you choose is the biggest time step that you can use in the WAQ model. In tidal and dynamic systems it would be wise to be in the range of 5-30 minutes. Otherwise I usually see time steps of 1-3 hours.
AR
Alexander Rey, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 1 Join Date: 10/20/16 Recent Posts
Hi,

I can jump in since I'm working with Fateme on this project, and I'm the one that made the hydrodynamic model at issue here.

A couple points of clarification:
1) We're not using WAVE, and are currently exporting the WAQ inputs from the control dialog box
2) The very short time step is required for the FLOW grid, since we're working on a very small area at high resolution (~400m long by 150m wide pond, with cells getting down to 1m2). I've tried running WAQ at a different time step, but hit an error saying it's not being scaled by an integer value (even if it is). Because of this, the WAQ time step is kept the same as FLOW.
3) This is a classic DD implementation, with three separate. non-nested grids. We implemented it this way in order to better handle some complicated geometry that occurs because of a baffle in the pond.
4) The time steps (and all other FLOW parameters) should be the same for all grids.

Really appreciate your help here- it's a cool project, but the shape of the system really need the DD in place, and it's creating a ton of hiccups trying to couple it.

Thanks,
Alexander
Michel Jeuken, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 156 Join Date: 1/21/13 Recent Posts
Hi,

Well, you should be able to set the output for WAQ at a higher interval than the FLOW calculation time step to reduce the size of the communication files for WAQ. Then you should be able to use a bigger time step in WAQ. What program complains about the time step, FLOW of WAQ itself?

It is a bit difficult to guess what goes wrong here. I think it helps if you post the three mdf files, and the three hyd files of the last run you tried.

You seem to be using an older (> 2 years old) version of the FLOW kernel, since the hyd file posted above doesn't contain a header.
Fatemeh GholamiMahyari, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 23 Join Date: 4/8/16 Recent Posts
Hi Dear Michelle

my time step problem solved by using your advise. When We put zero store communication intervals time step in WAQ is similar ti what we define in FLOW. As you said I just Ran the ddb file and used the hydro file with the same name of ddb file in the hydrodynamic section in define input. when I am open that hyd file it says that it can not open the discharge file. The error is as follow

Importing hydrodynamic description file:
D:\com-G7_DD_run2.hyd
--- other files will be imported from the
same directory

Importing discharges file:
D:\com-G7_DD_run2.src
Error opening file: Discharges file

scenario data changed!

what can I do now?? I would appreciate if you help me.

Thanks
Fateme
AM
Arjen Markus, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 223 Join Date: 1/26/11 Recent Posts
I think that the GUI merely presents an error message and then ignores the src file (it contains the discharge rates for the various sources included in the hydrodynamics). You can however define a timeseries of flow rates for these sources.

If not, could you post the hyd files and any src files? (Note: I can only respond next week at the earliest)
Fatemeh GholamiMahyari, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 23 Join Date: 4/8/16 Recent Posts
Thanks for your quick respond Arjen.
I defined the time series and my scn is completed but it can not run in waq1. When I try to run my scenario with error 1 it stooped. I attached the scenario file. By the way the flow module was running at the time when I try to rub the my scenario. Do you think I should wait until the flow complete the run and then I start working with WAQ?
I attached scn and hyd files.
Thanks
Fateme
AM
Arjen Markus, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 223 Join Date: 1/26/11 Recent Posts
Running a FLOW calculation and a WAQ calculation at the same time ought not to be a problem, unless the WAQ calculation is supposed to use the results of the FLOW calculation of course. If you run them in different directories, there should certainly be no problem.

Could you also attach the .inp and .lst files? The first is the input as presented to DELWAQ1, the second is the report. I will only be able to look at it on monday, but this should hold the secret of the reported error.
Fatemeh GholamiMahyari, modified 2 Years ago.

RE: Problem with coupling a ddb file

Youngling Posts: 23 Join Date: 4/8/16 Recent Posts
Thanks dear Arjen

I was ruining my model at the same directory as flow. So, I think that is the problem. I attached those file that you wanted. At the moment I am waiting for flow till the running ends then I can start working on WAQ.
Thanks again
Fateme
AM
Arjen Markus, modified 2 Years ago.

RE: Problem with coupling a ddb file

Jedi Knight Posts: 223 Join Date: 1/26/11 Recent Posts
Ah, indeed. The .lst file reports the attributes file to be missing and that is written by the hydrodynamic model (it represents the character of the grid cells, active or inactive, surface or bottom or in the middle - these are important characteristics for the water quality processes):

Selected file option is 1
Information from the standard input file.

Including file: com-G7_DD_run2.atr

ERROR: Include file does not exist !

ERROR. End card of block 3 not found !! Check input file !!

Okay, it should work indeed once the FLOW computation is completed. Let us know if you encounter problems even after that.