null

Message Boards

Error message: Improper version of watqual.d3d and proctabl.d3d

MU
Michael Ulmgren, modified 1 Year ago.

Error message: Improper version of watqual.d3d and proctabl.d3d

Youngling Posts: 5 Join Date: 1/19/17 Recent Posts
Hello!
I'm having an issue with the particle tracking (PART) module. After having downloaded and compiled the source code for Delft3D tag#7545 I was able to use the compiled executables to run a FLOW module, no problem. However, when I started up the PART module and clicked on Coupling - Define Input I get an error message stating that the waq_gui.exe cannot start correctly. After some looking around I noticed that under win64/waq/bin I have an waq_qui Error Log that states that:

WQ_ReadSystemFile: improper version of 'watqual.d3d'
WQ_ReadProcessTables: improper version of 'proctabl.d3d'

Now the interesting thing is that the desktop that I tried to run the PART module on will not start as I stated above. However, when I try to do the exact same thing on my laptop I'm able to start up the coupling and perform the coupling after just receiving two warnings about the improper version of watqual.d3d and proctabl.d3d. I was also able to run a a particle tracking simulation on my laptop with the coupled hydrodynamics.

I'm concerned though what the situation is with these two files that supposedly I have the wrong version of. How do I obtain the correct versions?

Note: I'm using the Delft3D GUI version 4.02.02.

Thanks for your assistance.

Michael Ulmgren
AM
Arjen Markus, modified 1 Year ago.

RE: Error message: Improper version of watqual.d3d and proctabl.d3d

Jedi Knight Posts: 222 Join Date: 1/26/11 Recent Posts
Hm, this is rather intriguing. While the two files that the GUI complains about are not essential for the "coupling" mode, these messages should not occur.

The two files should be found in the directory win64/waq/default. Could you tell us whether these files exist and if they do, what the line "version ...." says? (It should be: version 3 minor 33 in both cases)
MU
Michael Ulmgren, modified 1 Year ago.

RE: Error message: Improper version of watqual.d3d and proctabl.d3d

Youngling Posts: 5 Join Date: 1/19/17 Recent Posts
Hi Arjen,
Thanks for your reply. I do have both files in the default folder and they are both version 3 minor 32. So if they are supposed to be version 3 minor 33, it explains why the program states that I have the wrong version. Can you please go ahead and send me the correct versions of the files?

Thank you very much!

Michael
AM
Arjen Markus, modified 1 Year ago.

RE: Error message: Improper version of watqual.d3d and proctabl.d3d (Answer)

Jedi Knight Posts: 222 Join Date: 1/26/11 Recent Posts
I have attached the latest versions of these files as a zip-file. I do not think much has changed wrt the version you have - probably only the version number ;) - but I did not check that.
Michelle Jeuken, modified 1 Year ago.

RE: Error message: Improper version of watqual.d3d and proctabl.d3d

Jedi Knight Posts: 156 Join Date: 1/21/13 Recent Posts
I think the problem could have arisen from the fact the these files come with the GUI-setup, but are also in the open source code (https://svn.oss.deltares.nl/repos/delft3d/trunk/src/engines_gpl/waq/default). These versions are older, and should not be used. I've removed them from the oss-code in revision 8066