null

Message Boards

TELEMAC-Delft3D - Coupling

SS
Sumit Sinha, modified 7 Years ago.

TELEMAC-Delft3D - Coupling

Youngling Posts: 5 Join Date: 9/12/12 Recent Posts
Dear All,

This is in regard with coupling between TELEMAC3D and Delft. I have generated the relevant output files from TELEMAC and I am able to see the modeled domain in the visualization area under Delft-WQ gui (open source version). My problem is that I am not able to specify the boundary condition for water quality parameters that I want to simulate using Delft-WQ. I have used Delft suite of models before but always used it with structured mesh. As regards to TELEMAC it works with unstructured mesh. I was wondering if anyone has done successful coupling between TELEMAC and Delft water quality models. All help is greatly appreciated.

Kind regards,
Sumit
CT
Christophe Thiange, modified 7 Years ago.

RE: TELEMAC-Delft3D - Coupling

Jedi Knight Posts: 125 Join Date: 11/15/12 Recent Posts
Dear Sumit,

Could you describe some more what you mean with:

My problem is that I am not able to specify the boundary condition for water quality parameters that I want to simulate using Delft-WQ.

Do you see the TELEMAC boundaries in the Delft3D GUI or are they missing?


I was wondering if anyone has done successful coupling between TELEMAC and Delft water quality models. All help is greatly appreciated.

Yes, the TELEMAC-DELWAQ coupling has been around for several years now. It's been developed by EDF and Deltares and has since been used successfully by various TELEMAC users.

Regards,
Chris
LP
Leo Postma, modified 7 Years ago.

RE: TELEMAC-Delft3D - Coupling

Youngling Posts: 6 Join Date: 4/2/13 Recent Posts
Hi Sumit,

The Telemac simulation has a 'geo' file with the unformatted information on the FEM grid. The simulation also has an ASCII 'cli' file that specifies the domain boundaries. I call it 'geo' and 'cli', because that is often the name people give to it, but it may have different names as I understand. In the 'cli' file there is an indication of the edges that form the model boundary and the property of the nodes on those edges. You will meet closed boundaries (impermeable walls) and open boundaries there. If the boundary nodes have the right attribute (I think it is a 4 or a 5 in the first position of the row specifying the boundary nodes, 2 is for closed boundary nodes I think) then the WAQ-GUI should be able to identify the open boundary nodes and color them red in the visualisation area. You can then click them and attach through the gui concentration values to them.
In the first version of the coupling, of already some years ago, the open boundary nodes were not part of the model area in Delwaq. That gave some inconsistencies with Telemac, so now the open boundary node is part of the model area and it is assumed that there is a link 'from the outside of the model' towards the node. The flux of that link is computed from the Telemac hydrodynamic results. The concentratration can be specified through the Delwaq GUI.
I do not know how Telemac specifies nodes of influxes that are not open boundaries in the Delwaq sense (e.g. end-of-pipe wasteloads). If they do not, then you should be able to resolve everything through the open boundaries. If they do, then we might need to expand the coupling with that feature.
If not successful, please indicate (if successful you could do as well of course).

Leo
SS
Sumit Sinha, modified 7 Years ago.

RE: TELEMAC-Delft3D - Coupling

Youngling Posts: 5 Join Date: 9/12/12 Recent Posts
Hi Leo,

That is exactly my problem, I am not able to see the open boundaries in Delt-WQ . Although I was able to run the simulation I don't see the the open boundaries in DWQ. Please see the attached pic for better explanation.

As shown in the first pic DelftWQProb.tif, It does recognize the inflow boundary but not the outflow on the other end of the channel ( shown in DelfTMac.tif). Also I am not able to mark the open boundaries in DWQ interface. Even if I change the end index of the section in .scn file I don't see any color open boundaries in DWQ interface.

Do you have any idea what's going wrong ?

Kind regards,
Sumit
LP
Leo Postma, modified 7 Years ago.

RE: TELEMAC-Delft3D - Coupling (Answer)

Youngling Posts: 6 Join Date: 4/2/13 Recent Posts
Hi Sumit,

Looks like only the display of the boundary is lacking. We do not have that problem with Telemac here, so best is that you send us a copy of the Telemac unformatted grid file (is sometimes called the GEO file) as well as the Telemac ASCII boundary definition file (is sometimes called the CLI file), then we can see what goes wrong. If you want to do so as attachment to a mail or via upload to a secure ftp site rather than as attachement to a message at a forum, please send me an Email. (leo dot postma at deltares dot nl).

Regards,

Leo
LP
Leo Postma, modified 6 Years ago.

RE: TELEMAC-Delft3D - Coupling

Youngling Posts: 6 Join Date: 4/2/13 Recent Posts
The files have been sent by Sumit. It turned out that the boundary file (called cli file here) had comments behind the lines of information. That disturbed the GUI. After removing the comments the boundaries were visible.
An issue that remained was that an open boundary at the start of the cli file is not wrapped around with an open boundary at the end of the cli file. They appear as 2 different open boundaries. The solution to that is to move the lines in the cli file that specify the boundary at the start of that file to the end of the file.
Hope this addition helps future users.
AM
Ana Mendonca, modified 6 Years ago.

RE: TELEMAC-Delft3D - Coupling

Youngling Posts: 5 Join Date: 3/19/13 Recent Posts
Hello Pat,

Many thanks, it solved the problem.

Ana