null

Message Boards

Z-layers model, problem with boundary conditions in Delwaq

MK
Marcin Kawka, modified 6 Years ago.

Z-layers model, problem with boundary conditions in Delwaq

Youngling Posts: 11 Join Date: 5/31/11 Recent Posts
Hi,
I'm trying to model inorganic suspended matter in Delwaq. In sigma-layers model boundary condition works well, however due to lake stratification I would like to use z-model. Delft3d z-layer model of my lake works well with passive tracer so I assume that there is no problem with hydrodynamic part.
In coupling file I have manualy modified the following line:
geometry curvilinear-grid z-layers

In simulation results it looks like there is no influence of the boundary condition. Another strange thing is spatial result (attached picture). I am using 30 layers and in z-layer mode layer no.30 should be the top one, while I see a spatial pattern resembling the shape of the bottom one.

Are there any more changes I should do in simulation files in order to use z-layers instead of sigma-layers?

Regards,
Marcin Kawka
CT
Christophe Thiange, modified 6 Years ago.

RE: Z-layers model, problem with boundary conditions in Delwaq (Answer)

Jedi Knight Posts: 125 Join Date: 11/15/12 Recent Posts
Hi Marcin,

This is a known issue. The offline coupling does not work well with z-layers for the moment. You will have to use the built-in coupling instead. See this thread for more info.

Also, Delwaq uses another numbering convention than FLOW (from top to bottom, so layer 1 is the surface layer).

Good luck,
Chris