null

Message Boards

Problems with slow adsorption-desorption outputs in S1

FF
Fabricio Fiengo, modified 5 Years ago.

Problems with slow adsorption-desorption outputs in S1

Youngling Posts: 8 Join Date: 10/14/14 Recent Posts
Dear ,

My case study is designed as a batch reactor; it is just a square pond with stagnant water with constant depth, not subject to any forcing function or external source. I use this to verify the result of the radionuclide model that I am developing. While I was doing the verification of my results I found than, the results of the S1 were quite strange. Then I decided to repeat the same model schematisation for the modelling of Cd. My substances are:

IM1 in layer S1
Cd in layer S1
Dissolved mass Cd in layer S1
Particulate mass Cd in layer S1

In the first trial, I applied the slow sorption-desorption model for the partitioning of Cd with all the Cd dissolved in the pore water. The change in the fractions in the pore water and in the particulate phase were so small that after 1 month just the 2e-2 % of the total dissolved concentration was transfer to the particulate phase. Then I decided to debug the code and to print the internal computation, I realize that the values calculated internally were different from the values reported in the ‘his’ file. After verification, the internal computation were quite approximated to my control calculations (based on the formulae reported in the technical manual).

As a second trial, I repeat the same but this time the half life times were set to zero in order to represent fast sorption-desorption. The results in the ‘his’ file were the same as those calculated internally by delwaq, but for the dissolved mass Cd in S1 and particulate mass Cd in S1 the ‘his’ file shows values that decrease in time (like it was performing the slow case) while the values computed internally represent the equilibrium conditions as expected.

As a conclusion, based on my small experiment; the internal computations of slow sorption – desorption follow the model described in the technical manual, Why the results stored in the ‘his’ file are different?

For fast sorption – desorption, why the internal computation and the results printed in the ‘his’ file for the case of dissolved mass Cd in S1 and particulate mass Cd in S1 are different?

Attach you can find the substance file, the input files, an excel file with a summary of the comparison between internal computations and the values stored in the his file.

I hope you can help to understand or to solve the problem

Thank you very much in advanced

Fabricio

Attachments:

CT
Christophe Thiange, modified 5 Years ago.

RE: Problems with slow adsorption-desorption outputs in S1

Jedi Knight Posts: 125 Join Date: 11/15/12 Recent Posts
Dear Fabricio,

Could you mention which variables you printed out as debug statements or perhaps attach the modified file?

Thanks,
Christophe
FF
Fabricio Fiengo, modified 5 Years ago.

RE: Problems with slow adsorption-desorption outputs in S1

Youngling Posts: 8 Join Date: 10/14/14 Recent Posts
Dear Christophe

Inside 'partmp', I printed

FDIS, FPART, CDIS and QUAL, the modifications are in line 824 to 827

Thank you very much in advanced

Best regards

Fabricio

Attachments:

CT
Christophe Thiange, modified 5 Years ago.

RE: Problems with slow adsorption-desorption outputs in S1

Jedi Knight Posts: 125 Join Date: 11/15/12 Recent Posts
Hi Fabricio,

I ran your slow and fast simulations and exported the variables you mentioned for observation point (6,3) (i.e. segment 26) but could not see any difference with the values reported in the *.his files.

Just to make sure we are looking at the same things, this how variables in partmp.f compare to variables in the *.his files:
- variable FDIS is FrCdDisS1 in the his file
- variable FPART is not an output item
- variable CDIS is DisCdS1
- variabel QUAL is QCdDMS1

I attached my version of partmp with the output statements at line 802.

In your spreadsheet you also have Cdis and CPar masses printed from partmp, but none of the variables you mentioned in your previous post corresponds to these masses. Did you print any other variables to obtain these values?

Regards,
Christophe

Attachments:

FF
Fabricio Fiengo, modified 5 Years ago.

RE: Problems with slow adsorption-desorption outputs in S1 (Answer)

Youngling Posts: 8 Join Date: 10/14/14 Recent Posts
Dear Christophe,

You are absolutely right. I made the mistake to choose SEG=1 thinking that for all the segments the treatment was the same, but for the boundaries the area and volume of the segment is set equal to 1, while for the interior cells the volume is equal to cell area times depth

Thank you very much for your help and time

Best regards

Fabricio