intro story Lake

Lake

Lakes and reservoirs are important resources for communities around the globe. They provide food, drinking and irrigation water and can also offer spots for recreation. Under certain conditions lakes can also represent a threat for local communities, such as flooding or limnic eruptions. The ecological state of shallow lakes may be hampered by suspended sediments due to wind driven currents and waves. In deep lakes, stratification can cause undesirable anoxic conditions in the deeper areas. Understanding these systems is crucial to enable a sound management of these water bodies.

 
Delft3D is the state-of-the-art modelling framework for hydrodynamics, water quality, ecology, waves and morphology.
 
Here, in this space, we share knowledge & experiences, and discuss issues related to modelling of lakes.

 

** PLEASE TAG YOUR POST! **

 

 

 

Sub groups
D-Flow Flexible Mesh
DELWAQ
Cohesive sediments & muddy systems


 

Message Boards

Error running examples

Francesco Enrile, modified 5 Years ago.

Error running examples

Padawan Posts: 26 Join Date: 3/25/12 Recent Posts
Hi all,

I compiled Delft3D tag 5740 on Ubuntu 14.04 LTS using gfortran.
Everything seem OK but when I run the examples I always get the following error:

At line 831 of file prterr.f90 (unit = 33, file = 'tri-diag.f34')
Fortran runtime error: Sequential READ or WRITE not allowed after EOF marker, possibly use REWIND or BACKSPACE


However, this errors seems not to affect the result of the simulations.


Besides, when I run specifically example 10 I get:

At line 136 of file rdpart.f90 (unit = 902, file = '')
Fortran runtime error: File already opened in another unit

Delwaq2 did not run correctly.


Thank you very much for any help.
Best regards,
Francesco
U
Alejandra Ortiz, modified 4 Years ago.

RE: Error running examples

I am running into the exact same error when trying example 10. Does anyone have a good idea of how to fix this? I cannot run example 10 successfully (and am having issues with another Del-waq test case I've been trying).

Thank you,

Alejandra Ortiz
PR
perez roberts, modified 8 Months ago.

RE: Error running examples

Youngling Posts: 1 Join Date: 7/21/20 Recent Posts
Hello, I encountered the same problem. I am using Ubuntu 18.10 and got the error "Delwaq2 did not run correctly" in the installation process.I did some research to fix this problem and got rid of this problem thanks to this website. Or you can take the necessary actions in the article here.
JJ
Jason Josh, modified 1 Month ago.

RE: Error running examples

Youngling Posts: 1 Join Date: 3/8/21 Recent Posts
Is file "aclocal.m4" generated? If it is: does it give you more information? Can you post it here? If it isn't: Do you have write permission in this directory? Is there enough free space (1Mb should do)?

Is there any file with extension ".log" present, in the src root directory or subdirectory "log"? Can you post it here?
 
iMessageapp