General

At this page you can post questions or start discussions on general topics related to Delft3D Flexible Mesh.

Please select a proper category below (if possible), to post your message or reply to an existing post. Please add tags to your posts to simplify searching.

 

** PLEASE TAG YOUR POST! **

 

 

 

 


Back

RE: failed to download delft3d ( SSL handshake failed: SSL alert received)

KZ
KRIS Zh, modified 1 Month ago.

failed to download delft3d ( SSL handshake failed: SSL alert received)

Youngling Posts: 1 Join Date: 12/16/13 Recent Posts
Dear Community :

i cannot download delft3d when i use "svn co https://svn.oss.deltares.nl/repos/delft3d/trunk' delft3dtrunk "

[root@ip-172-31-6-166 ~]# svn co https://svn.oss.deltares.nl/repos/delft3d/trunk/ delft3dtrunk
svn: OPTIONS of 'https://svn.oss.deltares.nl/repos/delft3d/trunk': SSL handshake failed: SSL alert received: Handshake failed (https://svn.oss.deltares.nl)


also failed when "svn list "
[root@ip-172-31-19-177 ~]# svn list https://svn.oss.deltares.nl/repos/delft3d/trunk
svn: OPTIONS of 'https://svn.oss.deltares.nl/repos/delft3d/trunk': SSL handshake failed: SSL alert received: Handshake failed (https://svn.oss.deltares.nl)



OS: CentOS 6.9
[root@ip-172-31-6-166 ~]# lsb_release -a
LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID:    CentOS
Description:    CentOS release 6.9 (Final)
Release:    6.9
Codename:    Final



openssl:
[root@ip-172-31-6-166 ~]# openssl version
OpenSSL 1.0.1e-fips 11 Feb 2013


I try to upgrade openssl to 1.1.0f , not work.

But it's OK when i use AWS AMI to download delft3d

[root@ip-172-31-22-46 ~]# svn list https://svn.oss.deltares.nl/repos/delft3d/trunk
doc/
examples/
gpl-3.0.txt
lgpl-2.1.txt
src/
tsvn-auto-props



Thanks for any suggestion.
download svn ssl handshake
WJ
Wouter Jagers, modified 14 Days ago.

RE: failed to download delft3d ( SSL handshake failed: SSL alert received)

Youngling Posts: 1 Join Date: 7/14/15 Recent Posts
I've encountered the same issue.

Upon investigating, I think this is because Deltares' newest SSL certificate is using the x509v3 Subject Alternative Name extension for svn.oss.deltares.nl. The certificate itself is issued for oss.deltares.nl, and older tools seem to only check that.

Sadly, Centos 6 does not provide a more recent version of subversion and compiling one quickly leads to dependency hell.

However, the WANdisco repository does maintain more recent versions and provides an easy way to install.
You can find instructions on https://tecadmin.net/install-subversion-1-8-on-centos-rhel ; I've tried it on a test machine and it works.

Good luck !