Forum_general

General

At this page you can post questions or start discussions on general topics related to Delft3D Flexible Mesh.

Please select a proper category below (if possible), to post your message or reply to an existing post. Please add tags to your posts to simplify searching.

 

** PLEASE TAG YOUR POST! **

 

 

 

 


Message Boards

Unable to compile

HP
Huy Tran Quang Pham, modified 1 Month ago.

Unable to compile

Youngling Posts: 1 Join Date: 3/27/19 Recent Posts
Hello everyone,
Yesterday I just downloaded the D3DFM source code
(the latest, with highest number). Then I followed the instructions in
src/README to compile it. When it came to CFLAGS='-O2' CXXFLAGS='-O2'
FFLAGS='-O2' FCFLAGS='-O2' ./configure --prefix=`pwd` --with-netcdf
--with-mpi --with-metis --with-petsc, it failed, the final lines are:
(
gfortran: error: unrecognized command-line option '-showme:link'
gfortran: fatal error: no input files
compilation terminated.
configure: creating ./config.lt
config.lt: creating libtool
checking for the extension of Delft3D plugins... .so
./configure: line 20190: ACX_MKL: command not found
checking if PETSc is wanted... yes
checking for PETSc... no
checking for PETSc... no
configure: error: Package requirements (PETSc >= 3.8) were not met:

Package 'PETSc', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PETSc_CFLAGS
and PETSc_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
)
By
the way I'm using gcc & gfortran 10 (I know D3D ask me to use gcc
<8 but I tried many ways to downgrade, just can't, and I can't change
the OS, much more trouble), may be the "gfortran: error:" is because of
this? Other things are, I installed every prerequisites except that
gfortran version I can't go lower. But the terminal showed that the
program was unable to find mpi & petsc. For petsc you can see
clearly from above, for mpi it was a whole dozens of lines, I put them
in the attachment "err.txt". There were something unusual because I
compiled OpenFOAM succesfully (a software that require mpi too).
I tried again and again these two days,
and now I'm hopeless. Did search on forum, there were some questions
quite similar as mine but I can't use those solution. I really need
Delft3D, it is as a treasure to me but, I can't change the OS, how can I
compile successfully emoticon help me please.
Forgot to say, I'm using Fedora 32.

Attachments: