Migration status

Although the new site is live, work is still in progress to improve it.

Known issues:

  1. Forums: The organization of (sub-)categories and threads is disrupted. Please use the search box inside the "Message boards" to navigate.

Message Boards

Problem in Model Simulation

PG
Pragya Gangal, modified 1 Year ago.

Problem in Model Simulation

Youngling Posts: 3 Join Date: 2/13/18 Recent Posts

Hello

I have created the run file for my model, but could not complete simulation. Since there is no error message, I cannot understand the problem. As I understand from the list file (attached), iMOD couldn't read the top elevation file. Please suggest a solution.

Regards

Pragya

 

Frans Roelofsen, modified 1 Year ago.

RE: Problem in Model Simulation

Padawan Posts: 92 Join Date: 11/11/13 Recent Posts

Hello Pragya, 

Your RUN file looks OK.

And you are right, the standard MODFLOW echo is found in the LIST file. iMODFLOW has no additional echo lines.

It seems like iMOD stops when reading the IDF for the TOP module.

Strange enough it is the same IDF you refer to in the Boundary File part (dataset 9).

Therefore I'd like to debug your model with the original datafiles.

--> can you send me the ELEVATION.IDF file?

(share it on the forum or send it to my e-mail address: frans.roelofsen <at> deltares.nl

Kind regards,

 

Frans
 

PG
Pragya Gangal, modified 1 Year ago.

RE: Problem in Model Simulation

Youngling Posts: 3 Join Date: 2/13/18 Recent Posts

Hi Frans

I have emailed you the data files for the model as the file size is too large to be attached here.

Thanks & Regards

Pragya

Frans Roelofsen, modified 1 Year ago.

RE: Problem in Model Simulation

Padawan Posts: 92 Join Date: 11/11/13 Recent Posts

Hi Pragya, 

You use the option NSCL=0 in the RUN file to define the model network (model window and cell size) for you model.
This means that the IDF file in "Dataset 9: Boundary File" defines your network. That is in your case file ELEVATION.IDF.
Based on the dimensions of this IDF file iMODFLOW checks of all additional given model files overlap this dimensions.
This should be no problem in your case: your files have the samen dimensions.

However, your IDF files have floating values for xmin, xmax, ymin, ymax and cell size.
I found out that it seems that iMOD doesn't like that.
You can see that from the DOS window that is opened when you run iMODFLOW (see attachment).
IMODFLOW indicates that the dimensions of your (TOP) file ELEVATION.IDF undersizes your modelnetwork (given by ELEVATION.IDF).

How to continue?
- I start an issue to fix this in the next iMODFLOW release
- you can run your model by making a small change to your RUN file (example given below):
  * instead of defining the area you model by ELEVATION.IDF, you should define it by giving the xmin/xmax/ymin/ymax dimensions
  * you change the 5th (NSCL=1) keyword on line 2
  * you change the 1st (NMULT=1) keyword on line 3
  * you insert line 5 (Dataset 6). See that the xmax and ymax are slightely smaller.

New RUN file lines 1- 7 look like:
"C:\IMOD\IMOD_USER\MODELS\M3"
1,1,1,0,1,0,0,0,0,0,0
1,0,0,0,0,0,0.000E+00,0.100E-02
150,20,0.100E-03,0.100E+00,0.98,1,0.010
202259.8  2986788  403576  3322591 29.47977 0
ACTIVE MODULES
 1  0 (TOP)

.......

 

This change in the RUN files works on my laptop. It should work for you to.

However, I get a virtual memory error; the number of model cells is to large for my laptop.

In case you experience that too you can check 2 options:

- run your model for a smaller window, just covering the area with active modelcells.

- run you model first on a larger scale (e.g. 250 m) and use the results (heads) as boundary condition for a series of subwindows with the original cell size.  (I can give you some suggestions if you like) 

- in case you have more CPU's at your disposal you can try to run your model parallel (see manual chapter 2.3 about the Parallel Krylov Solver (PKS) package.")   

 

Kind regards, 

Frans

PG
Pragya Gangal, modified 1 Year ago.

RE: Problem in Model Simulation

Youngling Posts: 3 Join Date: 2/13/18 Recent Posts

Dear Frans

Thanks for the reply. I adopted the changes you suggested, but am still unable to run the model. I have tried reducing the simulation area to active model area, and with 250m resolution. However, each time I try to convert xmax, ymax etc. to an integer value, it automatically reverts to floating value during simulation. Again there is no error message in the DOS window. Please suggest a possible solution.

Thanks & Regards

Pragya

Frans Roelofsen, modified 1 Year ago.

RE: Problem in Model Simulation

Padawan Posts: 92 Join Date: 11/11/13 Recent Posts

Hi Pragya, 

 

With the RUN file you sent me (and the model files you sent before) I can run the model without any error. 

I only substituted in the RUN file your file "C:\IMOD\IMOD_USER\FILES\IMOD\HEAD.IDF" with the file you sent "Head.IDF". 

Can that fix the problem?

Thank you for also sending the LIST file with the standard MODFLOW echo. However from that file I do not get enough information. 

 

* you write "However, each time I try to convert xmax, ymax etc. to an integer value, it automatically reverts to floating value during simulation." 

--> I do not understand what you mean by 'convert'. In the RUN file? But your RUN file is OK. Based on what do you conclude that "it automatically reverts"?  

* you write "Again there is no error message in the DOS window". 

--> Can you in spite of that please send a screendump of your DOS window?

If you run your model from iMOD, the DOS window will be closed right after running your model. In that case you can not read the echo line.

I suggest you to run iMODFLOW outsite the iMOD Graphical User Interface. How? 

Open a DOS window. Goto the directory with the iMODFLOW executable. Run iMODFLOW with the command "iMODFLOW_V4_2_METASWAP_SVN1233_X64R.exe IMODFLOW.RUN".   

 

Kind regards, 

 

Frans