Migration status

Although the new site is live, work is still in progress to improve it.

Known issues:

  1. Forums: The organization of (sub-)categories and threads is disrupted. Please use the search box inside the "Message boards" to navigate.

Message Boards

Several GEN file problems

YV
Ylva Veldhuis, modified 2 Months ago.

Several GEN file problems

Youngling Posts: 3 Join Date: 11/12/19 Recent Posts
Hello,- I’m working on a groundwater model in iMod and I’m trying to create an IDF file from a GEN file, but everytime imod shuts down when I try that.
- I have also tried to use the GEN file in the IDF edit, this does work but with a small hassle because imod does not recognize the 7 polygons but all the polygons before merger in ARCmap eventhough the polygon names are the ones used after the merge.
- When I try to use the GEN file for grid refinement it again does not work because the GEN file does not have a gridsize and I do not know how to change this.I have an GEN file which I made with ARCmap (GIS), this GEN file has the information where the water paths are for a small part in the Netherlands. I have reduced the amount of polygons to 7 because I merged them together in ARCmap.I have read all the threads here about GEN to IDF file conversion but nothing helps. I have included my GEN file and my ahn file where I have used the gen file in. 
Kind Regards,
Ylva
gen
FR
Frans Roelofsen, modified 2 Months ago.

RE: Several GEN file problems

Padawan Posts: 87 Join Date: 11/11/13 Recent Posts
Dear Ylva,Thank you for your Post. 
In my role as moderator I like to move your post/Tread to another category in the forum. It will be the category Home --> iMOD-GUI --> Report a problem / bug. 
A post placed in a category is sent to all subsribers of that category which helps that your issue is answered soon. Kind regards,Frans Roelofsen
< moderator iMOD website >
FR
Frans Roelofsen, modified 2 Months ago.

the thread is moved

Padawan Posts: 87 Join Date: 11/11/13 Recent Posts
the thread is moved
FR
Frans Roelofsen, modified 2 Months ago.

RE: Several GEN file problems

Padawan Posts: 87 Join Date: 11/11/13 Recent Posts
Dear Ylva,

Thanks for sending you GEN file. Very helpful. Now we where able to reproduce your issue, and fix it.

What is the case: iMOD needs integer or float values for gridding. In case a text string is found, iMOD will stop with a message.
Your GEN file only contains text for each polygon. That is the reason why iMOD stops. However, before a proper stop message was presented, iMOD crashes on some internal issue. In the window Attribute Value there is the option to (de)select which column is used for gridding. This option did not work properly. It is fixed; in case the option is not selected iMOD will use the polygon order number as a value for gridding.

We are in de process of releasing iMOD 5.0. In that version this fix is included. The new version is expected to be released in December.
In the meantime there is a word around: add a column to you Shape/GEN file with a float/integer value. The column should be column 1. In the attachment you find a version I created for you.
Hopeful it works for you.

Kind regards,
Frans Roelofsen