Migration status

Although the new site is live, work is still in progress to improve it.

Known issues:

  1. Forums: The organization of (sub-)categories and threads is disrupted. Please use the search box inside the "Message boards" to navigate.

Message Boards

GEF2IPF doesn't operate

Noud Dijkema, modified 3 Months ago.

GEF2IPF doesn't operate

Youngling Posts: 7 Join Date: 11/20/19 Recent Posts
Hi there,

For my research I want to model the spread of some neonicotinoid from meadows, through a water way towards the Wadden Sea.

To start my model I want to create the subsurface around my waterway. I want to do this by using data from boreholes, acquired from the DINOloket-database, which is in .GEF files. I wanted to use the iMod Batch function ''GEF2IPF" for this goal, but I can't seem to get it working.
At first I tried to create .INI file in notepad. In this INI file I wrote all the obligatory keywords and added the paths, as explained in the user manual. During this try I consistently got two messages 'iMod can't open gef2ipf.ini' and 'can't open gef2ipf.ini'. As I'm still a beginning programmer, I deleted this file and started all over again. Sadly I didn't take a screenshot of this.

In my second try I used the iMod GUI to create the .BAT file (edit -> iModbatch) and fill in all the paths required for the GEF2IPF. I added a screenshot for this. Executing this .BAT through iMod, it will give the message "IMOD DID NOT find keyword: [IPFFILE] within settings File:{ini location}". This is probably caused by the fact that the .BAT file uses the word "IPFFname" and iMod is looking for "IPFFILE"? I changed both the names in the .INI and .BAT to IPFNAME and IPFFile, both didn't work. Changing to FILE would lead to a shutdown of iMod.
To prevent this from happening, I use the command prompt and enter "{installfolder}\iMod\iMOD_V5_0_X64R.exe gef2ipf.ini" to start the conversion. But again I receive the warning that iMod can’t open the file.

I am sure iMod can do the calculations, as the DINO-database is referred to in the user manual to, but in the .CSV format. Furthermor,e the program works properly too. When the batch function located at “iMod\TUTORIALS\TUT_Map_Analyse\SubsoilSystem” is operated, the program works without a problem.

I’ve been looking for a solution for quite some time now, but I can’t seem to get it working. Can anyone assist me on this problem? Any help would be greatly appreciated.

Kind regards,

Noud Dijkema

Edit: I tried running the GEF2IPF today and somehow I managed to run the script for a blink of an eye before closing down. I managed to get a screen shot of the error in the cmd prompt. It gives a syntax error and a problem with my list, so I suppose my GEFs arent compatible with iMod? Added another screenshot of the prompt. 
Frans Roelofsen, modified 3 Months ago.

RE: GEF2IPF doesn't operate

Padawan Posts: 99 Join Date: 11/11/13 Recent Posts
Hi Noud,Thank you for your Post with your question about the function GEF2IPF.In my role as moderator I like to move your post/Tread to another category in the forum.
It will be the category Home --> iMOD-GUI --> User Questions
We hope that these different categories help the community to find answers to their questions too.I am also member of the iMOD development team. With that experience I will also have a look at your issue.  Kind regards,Frans Roelofsen
< moderator iMOD website >
Frans Roelofsen, modified 3 Months ago.

RE: GEF2IPF doesn't operate

Padawan Posts: 99 Join Date: 11/11/13 Recent Posts
Hi Noud, In order to reproduce your issue, can you attach one or two of your GEF files? Frans
Frans Roelofsen, modified 3 Months ago.

RE: GEF2IPF doesn't operate (Answer)

Padawan Posts: 99 Join Date: 11/11/13 Recent Posts
Hi Noud, Your GEF files are OK. I found out that iMOD also needs to know what type of GEF file is given. Therefor the keyword GEFTYPE is given. Your GEF files are borelogs so choose GEFTYPE= 2.See also the documentation of this function in the manual chapter 8.7.4 GEF2IPF-Function.  The keyword WINDOW and GENFILE are optional. I fixed the code on this. 
So for now, please rewrite your *.BAT script file as below: 
echo FUNCTION=GEF2IPF                              >  gef2ipf.ini
echo GEFDIR= N:\Teams\Helpdesk-iMOD\imod\PR\forum\posts\2913627\gef >> gef2ipf.ini
echo IPFFile= N:\Teams\Helpdesk-iMOD\imod\PR\forum\posts\2913627\borelogs.ipf                                 >> gef2ipf.ini
echo GEFTYPE= 2                                  >> gef2ipf.ini
"C:\imod\imod50\iMOD_x64_d.exe" gef2ipf.ini

Kind regards, Frans