Migration status

Although the new site is live, work is still in progress to improve it.

Known issues:

  1. Forums: The organization of (sub-)categories and threads is disrupted. Please use the search box inside the "Message boards" to navigate.

Message Boards

Tutorial 4 Error

NV
Nadine Vogel, modified 4 Years ago.

Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello everyone,
I already had some problems with the Model Simulation. I always got the error "an error occurred" but nothing else. After trying it several times it worked out somehow.
But now I have problems with the Pathline Simulation. Everytime when I want to start the simulation it says:
"iMod cannot open file: ..." (see file attached)
I already changed the working folder, because I found one with a ".". But it does not work anyway.
Has anyone an idea how to solve this?
Kind regards, Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
HI Nadine,

Yes, unfortunately this is a known bug. We have solved this and the bugfix will be part of the coming release, scheduled 15/6. However, a work-around for now would be to use the iMODBatch function called IMODPATH instead, just have a look at the iMOD Manual how to use this function. The runfile for iMODPATH is created and probably saved in the result-folder. You could use that file to start the particle tracking simulation. Often it is also most convenient to (re)start your particle simulation using the iMODBatch function.

Please let me know if there is anything else I can do to assist you.

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
thank you for letting me know! I will have a look in the manual again on how to use the batch function called iModpath and try to use it for the particle simulation.
If there are still problems left, I will let you know.
Kind regards,
Nadine
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello Peter,
unfortunately I still have a little problem.
So I created a file called imodpath.run with function=imodpath and runfile=C:\...\pathlines.run. And of course I created the file pathlines.run similar to the example in the manual.
But I haven't managed it yet to start the pathline simulation.
I am not quite sure on how to run the runfile. First I tried to just open the imodpath.run file in the Explorer with iMod.exe. But I get an error that says "error reading parameter in runfile. IMODE(.)".
I thought the problem might be that there are two numbers (1,1). So I tried different ways with spaces, another comma etc. But always the same error occurred.
When I try to open the imodpath runfile with iModflow, nothing happens.
And I tried to open it via iMod Batch, but I didn't really find it in the manual how to do this the right way. I created a batch script for Imodpath. As there are referrals to imodpath.ini everywhere, I opened that file and entered C:\...\pathlines.run behind runfile. Then I tried to start the Imodpath.bat file. But nothing happend except for a change in the imodpath.ini file. My entered C:\...\pathlines.run for the runfile got deleted again and replaced by three dots.
So in general I have two questions. Is it possible to just open the imodpath.run file in the Explorer with iMod.exe? And if so, do you have an idea, on how I could change the parameter of iMode so that it would work out?
Kind regards,
Nadine
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello Peter,
I still have a problem with running the pathline simulation.
I solved the problem that I hade with iMode (1,1). The problem was, that in the manual it is said, that NSDF should only be entered, when it is > 1. So I left it empty resulting in iMod having problems to define the other parameters right. Therefore it read my outfile as imode. I entered 1 for NSDF now, resulting in iMod having problems with other parameters.
It had a problem with "MAXT" because I skipped "STOPCRIT". For stopcrit it is said, that it is only applicable when NPER > 1. If I enter 1 for stopcrit even if I just have 1 for NPER the next issue is the "STARTDATE" (only necessary when NPER > 1). And I guess that even if I invent anything for that parameter iMod will have problems with "SWINDOW" and "EWINDOW" because these are also mentioned to be only necessary when NPER > 1.
Is there a way to let iMod run a pathline simulation without inventing values for these parameters?
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

It is supposed to be very simple to start pathline simulation by iMODBatch:

Create a file IMODPATH.INI containing:

FUNCTION=IMODPATH
RUNFILE=d:\iMOD-TEST\IMODBATCH_IMODPATH\IMODPATH.RUN


and then start the simulation by:

IMOD.EXE IMODPATH.INI

You should leave the NSDF line completely whenever you have only a single SDF file. Send me your IMODPATH runfile, so I can have a look.

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello Peter,
if I try to start it this way, nothing happens. It "works" if I make a runfile containing FUNCTION=... and RUNFILE=... and start it with iMod by a right klick with the mouse choosing iMod to start it.
But then I get those errors. I attach some screenshots.
If I leave the NSDF completely, I get the error that iMod can't read the parameter IMODE. Picture 3 shows the runfile and the error with the black box. There you can see, that it actually writes the startpoint ISD file behind the place where the outputfile should be (IFFNAME). That is why I thought, that my parameters are kind of shifted because of my lacking NSDF input.
If I enter 1 for the NSDF I like in picture 1, I get the error, that iMod can't read TMAX. In the black box it can be seen, that iMod might take my tmax for the stopcrit. And the next input in the runfile is then the boundary file which iMod can't read if it thinks that at this place TMAX should occur. Therefore I guess there is the error with reading TMAX.
This is supported by the fact that if I enter a value for stopcrit the next error says, that iMod can't read the parameter of the startdate (picture 2). This would be placed below TMAX in the runfile but there is my boundary file which is why iMod might not be able to read it as startdate.
I don't know, which other reason should underlie these errors except that iMod reads the parameter wrong due to missing ones.
But I also attach my original runfile without NSDF and stopcrit, maybe you find something else.
Thank you very much,
kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

I think the runfile need to be as follows:

3, !## NLAY
1, !## NPER
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\STARTPOINTS\ISLAND.ISD
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\pathlines.IFF
1,1 !## IMODE
0, !## IFWBW
3, !## ISNK
0.50, !## FRACTION
1 !## stop criterium
1.000E+31, !## MAXT
19960101 !## STARTDATE
20000101 !## ENDDATE
20000101 !## ENDWINDOW
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\surfacelevel.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\slevel-1.IDF, !## BOT
0.3, !## PORAQF
0.1, !## PORAQT
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\slevel-1.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot2top3.IDF, !## BOT
0.3, !## PORAQF
0.1, !## PORAQT
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot2top3.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot3.IDF, !## BOT
0.3, !## PORAQF
0.1, !## PORAQT
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfrf\bdgfrf_steady-state_l1.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfff\bdgfff_steady-state_l1.IDF, !## BDGFFF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgflf\bdgflf_steady-state_l1.IDF, !## BDBFLF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfrf\bdgfrf_steady-state_l2.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfff\bdgfff_steady-state_l2.IDF, !## BDGFFF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgflf\bdgflf_steady-state_l2.IDF, !## BDBFLF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfrf\bdgfrf_steady-state_l3.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgfff\bdgfff_steady-state_l3.IDF, !## BDGFFF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\bdgflf\bdgflf_steady-state_l3.IDF, !## BDBFLF

Don't put emtpy lines in between. The only variable that you might leave out is NSDF. ALthough you have a steady-state, you need to include the start- enddate and endwindow, doesn't matter what you fill in there though. To start the iMODBatch function start a commandwindow (cmd) and type in:

imod.exe imodpath.ini.

See for more reference the iMOD Manual the section iMODBatch.

Kind regards,
Peter
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello Peter,
thank you for your answer. I didn't know, that empty lines would cause such problems.
As for the start and end date I thought that it is also possible to leave them out, because the manual says, that these are only necessary whenever NPER >1. But I included them now.
Unfortunately I get another error again.

If I try to start the imodpath.ini file with the cmd commander, the licence agreement window appears, which I accept. But anyhow, an error occurs saying "iMod cannot open file: \I_accepted_V3_3.txt". After clicking okay it says "iMod cannot save licence file:\I_accepted_V3_3.txt". And after that it says "Can not start iMod unless you accept the iMod Software License Agreement" (which I actually did). I don't know, where the problem is. I even tried if it changed something if I copy everything in one folder, the imod.exe, imodflow.exe, netcdf.dll and the imodpath.ini and even included then for another try the imod_init.prf and the I_accepted.txt file from tutorial 4 but still the same errors.
Do you know why why I get these errors or rather how to avoid them?

If I open a runfile, containing Function=imodpath and Runfile=\...\pathlines.run, by a right-click and say to open it with imod.exe and having my runfile changed the way how you posted it yesterday it stops at the third entry of PORAQT. It reads PORAQF (0.3) and after that it already says "BDGFRF for layer 1=0.1" in the black box at the place where PORAQT (0.1) should actually be (picture attached). I don't know, why it doesn't say "Por Aquitard3=0.1" at this place.
Anyway I wondered what would happen if I just delete that third PORAQT value. Then iMod reads all input files except for the last BDGFLF file and says "iMOD cannot open file:.\imodpath.log".
I don't know what the problem is there.

Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

For a three-layered model there is no porosity for the third aquiclude, because there is none. So you should remove the POR_AQUITARD3, also there is no BDGFLF_L3 because there is no vertical flow from layer 3 to layer 4 (that doesnot exist). So, I thing you're almost there, a small thing that might help is to avoid the local-pathname by a global pathname, so instead of

..\..\pathlines.run

use something like

d:\imod\pathlines.run

if that is the location of the runfile, ofcourse. All the problems that you've faced, are solved in the coming release. Thanks for sharing these with us.

Kind regards,
Peter
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hello Peter,
thank you very much. I didn't think of that because they existed in your example.
But even if I remove these parameters, I still get the error, that says: "iMod cannot open file:.\imodpath.log".

I used \...\pathlines.run just to shorten it up a little.
My imodpath.run file actually looked like this:
FUNCTION=IMODPATH
RUNFILE=C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\RUNFILES\pathlines.RUN

and my pathlines.run file like this:
3, !## NLAY
1, !## NPER
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\STARTPOINTS\ISLAND.ISD
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\pathlines.IFF
1,1 !## IMODE
0, !## IFWBW
3, !## ISNK
0.50, !## FRACTION
1, !## STOP
1.000E+31, !## MAXT
19960101 !## STARTDATE
19960101 !## SWINDOW
20000101 !## EWINDOW
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\surfacelevel.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\slevel-1.IDF, !## BOT
0.3, !## PORAQF
0.1, !## PORAQT
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\slevel-1.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot2top3.IDF, !## BOT
0.3, !## PORAQF
0.1, !## PORAQT
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\DBASE\boundary.IDF, !## IBOUND
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot2top3.IDF, !## TOP
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\SHAPES\bot3.IDF, !## BOT
0.3, !## PORAQF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFRF\BDGFRF_STEADY-STATE_L1.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFFF\BDGFFF_STEADY-STATE_L1.IDF, !## BDGFFF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFLF\BDGFLF_STEADY-STATE_L1.IDF, !## BDBFLF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFRF\BDGFRF_STEADY-STATE_L2.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFFF\BDGFFF_STEADY-STATE_L2.IDF, !## BDGFFF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFLF\BDGFLF_STEADY-STATE_L2.IDF, !## BDBFLF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFRF\BDGFRF_STEADY-STATE_L3.IDF, !## BDGFRF
C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\MODELS\ISLANDQ500\BDGFFF\BDGFFF_STEADY-STATE_L3.IDF, !## BDGFFF

And iMod still stops at the end with the error mentioned above ("iMod cannot open file:.\imodpath.log").
Do you know anything how to work around this? Or should I wait for the new release to have a pathline simulation that works out?
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,m

Yeah correct! I've changed the manual accordingly, thanks!

iMOD want to save a file imodpath.log at the place where you start iMOD, do you have the right to create a file in that folder?

Kind regards,
Peter
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi,
yes I should have the right to create a file in that folder. I already created some.
And normally when I start iMod it has no problems to create the IMod_INIT.prf itself and the I_accepted_V3_3.txt file. And during modeling it also has no problems to create all those outputfolders like in tutorial 6 (BDG folders and files).
So could there be anything else that iMod needs to proceed?
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
HI,

I've looked in the code thoroughly - I don't see any problem unfortunately. The only thing that could happen if you have an interfering error, iMOD didn't closes the *.log file and therefore it is unable to open it again if you try another simulation. The only thing that might help, is to restart iMOD in that case.

For the coming release the *.log-file is saved in the result folder, perhaps this overcomes future errors,

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
thanks for checking the code again.
Unfortunately a restart of iMod doesn't change anything.
But another thing striked me now. Even after my normal model simulation, there is no *.log file saved anywhere. There is just a file called log_v3.3.txt that iMod saved in the model folder. And this file just says:

MODEL SIMULATION - SUMMARY

and nothing else.
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

That is strange, didn't the groundwater model converge beforehand? I thought you had simulated this successfully?

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
yes the groundwater model was simulated successfully.
iMod created the different files for example for the heads and I could open them in iMod to see the differences for the different layers. Also the IMODFLOW.list file contained the same information as shown in the manual. Just the log_V3.3.txt file is empty.
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,

Okay, yes, that is right, that log-file is only meant when the runfile is transferred to the Modflow2005 packages. The log-file of the model simulation you should examine, when something goes wrong, is the *.lst file in the output folder.

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
okay, I was just wondering, which log file is meant then in my error. Because you said, that iMod might have not closed it which is why it might have the problem with not being able to open it again.
But I couldn't find any *.log file. I just found that log.txt file and then I was confused because it was empty.

But if iMod never created that imodpath.log file before, the problem cannot be that iMod hasn't closed it and can't open it again. So there has to be a different problem.
In Tutorial 7 I have a similar problem (https://oss.deltares.nl/web/imod/forum/-/message_boards/view_message/913377).
iMod says that it can't open different files but it hasn't even created them before. So could it be, that this problem with the imodpath.log file in tutorial 4 might be the same like in tutorial 7? And if so, do you have an idea how to solve this?
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,

The problem with the .\imodpath.log can be overcome whenever you copy the iMOD.exe into the result folder and use that iMOD.exe to start your iMODBatch function. Could you try that?

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
I don't know if there might be another problem.
For now I always tried to start the simulation by opening a runfile containing Function=imodpath and Runfile=\...\pathlines.run, by a right-click and say to open it with imod.exe. Doing this, I cannot specify which exe should be chosen. So I cannot start it with the one that I copied in the results folder.

I did it this way because if I try to start the imodpath.ini file with imod.exe in the total commander, the licence agreement window appears, which I accept. But anyhow, an error occurs saying "iMod cannot open file: \I_accepted_V3_3.txt". After clicking okay it says "iMod cannot save licence file:\I_accepted_V3_3.txt". And after that it says "Can not start iMod unless you accept the iMod Software License Agreement" (which I actually did). I had no idea why that happened or how I could make iMod accept it. I tried different ways, also to start iMod first and have a license file saved but anyhow the error still existed. Also if I copy imod.exe in the result folder.

Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,

Okay, do as follows:

Make a file called run.bat and put the following statement in it:

imod.exe imodpath.ini
pause


and then double-click this file from the TotalCommander or any other explorer. Maybe the problem is in the way you start the iMODBatch function.

Alternatively you can make a batch-file that creates the ini at the same time (see below and attachment), sometime even more handy:

echo FUNCTION=IMODPATH > IMODPATH.INI
echo RUNFILE=d:\iMOD-TEST\IMODBATCH_IMODPATH\IMODPATH.RUN >> IMODPATH.INI

D:\OSS\IMOD\bin\IMOD_X64_D IMODPATH.INI

PAUSE


Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
I already tried to start it with a batch file. A black window appeared and disappeared real quick. But nothing else happened.
Now I made another file as you said and I could actually read the black window due to the pause command. Whenever I click another key to make it go on, it dissappears. But I made a screenshot. I will attach it. Maybe you know with that picture then what is going wrong...
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

Thanks for the screenshot, I think you miss a drive-letter for the runfile. Moreover, you could leave out the ICONVERTGEN option.

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
thanks, this was a mistake that I did in a hurry, as I made a new file.
But anyway the drive-letter doesn't change anything, as you can see in the attachment. And as soon as I press another key the window disappears again and nothing else happened.
Could the ICONVERTGEN option be a problem? Because I don't know, where I should leave it out.
The only input parameters in my bat file are the imod.exe and the imodpath.ini.
The imodpath.ini contains FUNCTION=IMODPATH and RUNFILE=C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\RUNFILES\imodpath.run. There are also other parameters listed with =... behind them (IPOSTP, IFFFLOW, IPFFLOW, IDFFLOW, IPFFNAME, IXCOL, IYCOL, ILABELCOL, ILAYCOL). I didn't specify those. But ICONVERTGEN isn't mentioned there. And it neither isn't mentioned in my imodpath.run file. And another file isn't used. So I don't know, where I could leave out that option.
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,

Okay, correct iMOD echoes the keyword ICONVERTGEN, also whenever you do not specify it.

What do you mean with:

There are also other parameters listed with =... behind them (IPOSTP, IFFFLOW, IPFFLOW, IDFFLOW, IPFFNAME, IXCOL, IYCOL, ILABELCOL, ILAYCOL).

It is not allowed to enter keywords without any argument behind the "="-sign. You need to leave them out of the ini-file. The ini file should only contain keyword for which enter arguments. Can you send my your ini-file?

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
sorry I didn't know, that this was not allowed. I actually deleted them first. But when I still had those problems I tried to leave the imodpath.ini file the way iMod created it and just adjusted the parameters I knew. My My imodpath.ini file looks now like this:

FUNCTION=IMODPATH
RUNFILE=C:\Users\vogeln\Documents\TUT4_Initial_Modeling\IMOD_USER\RUNFILES\imodpath.run

I get a simulation now, but I will have to examine it more precisely tomorrow, because there is a big gap between the pathlines at the well and the pathlines at border of the model.
I might come back to this if I don't find a way to have them connected.
Kind regards,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error (Answer)

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi,

Alright, great !!! Congrats :-) We will make sure nobody else can make this "mistake" with the ini-files. Thanks for that.

Anyhow, remember that particles cannot be started whenever they are located above or beneath the top- and bottom elevation of your model. I think your particles are at the groundwater level, and it seems that at the "empty" spots, the groundwater head (and therefore your particles) are above the top elevation of your model. Try to put the particles at the top elevation instead.

Kind regards,
Peter Vermeulen
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
yes you are right, the manual said to use the computed hydraulic head of layer 1 as top and as bottom layer for the starting points. I created those two weeks ago and didn't think of that yesterday.
But it works fine now emoticon
Thank you very much,
Nadine
PV
Peter Vermeulen, modified 4 Years ago.

RE: Tutorial 4 Error

Jedi Knight Posts: 135 Join Date: 11/11/13 Recent Posts
Hi Nadine,

Okay, that is good news! I'm glad that I could help you.

Do you attend the iMOD webinar next week ?

Kind regards,
Peter
NV
Nadine Vogel, modified 4 Years ago.

RE: Tutorial 4 Error

Padawan Posts: 47 Join Date: 4/26/16 Recent Posts
Hi Peter,
Thanks for the advice. I haven't noticed the iMod webinar yet. I will check it out and see if I have time and if I am allowed to attend it.
Kind regards,
Nadine